The Diesel Garage banner

1 - 4 of 4 Posts

·
Junior Member
Joined
·
3 Posts
Discussion Starter #1 (Edited)
This is my first Diesel. I just noticed an issue that i can not figure out.

on acceleration there is a chugging noise, it will not get over 5psi of boost. once i get up to speed and cruise the noise goes away. I checked all the CVC boots and all is good. only modification i can tell on the truck is aftermarket intake and exhaust.

I have heard that it might be EGR issue- i dont know how to check or possible a turbo actuator issue, but i dont know if that will cause the chugging.

any experts on here that can help me diagnosis this issue. Please help ASAP, I have a trip in a month to SC to help grandparents move, and we need the truck!

Picture of my baby:
https://drive.google.com/open?id=1Z4Fh4bNe4MUyfbTrpU-jZwhcmiX3WK2x

Video of the Chugging sound:
https://drive.google.com/open?id=1o9C36SBRnMpf0tUZzgcUOhk4hVsy-2eK

Steven Sullivan
Noblesville, Indiana
 

·
Junior Member
Joined
·
3 Posts
Discussion Starter #2
UPDATE:

I took the ERG housing off and was unable to remove the actual EGR. I cleaned everything as best as i could, put it back together and took it for a test drive no changes.

I did notice that there is a modification that i didnt notice previously. so the list of mods are as follows...

1) Intake
2) Exhaust
3) ERG Cooler delete

Please help me figure this out!
 

·
Junior Member
Joined
·
3 Posts
Discussion Starter #3
UPDATE:

I took off the EBP and cleaned it and the down tube. The chugging noise is still there on acceleration!

The turbo actuator- I can move the lever with engine off, it returns back, with the engine on the lever will not move. This makes me think that the actuator is working right. however, i am still only getting 5 PSI of boost.

Video of the Chugging sound:

drive.google.com/file/d/1o9C36SBRnMpf0tUZzgcUOhk4hVsy-2eK/view
 

·
Registered
Joined
·
2 Posts
Hi
Judging from the video, this sound really makes me think it's comming from the aftermarket intake, as it correlates with the whining of the intake. As it's aftermarket maybe the job was done teribly, and of the hoses are loose and with the pedal down it starts to vibrate making this odd sound. Just have a good look.
Since you also took a look at the actuator, have a look at the turbo itself. Low boost= wierd noices on accelelator does also look like a bad turbo. But when turbos are bad usually they tend to spin faster then they can cope, going into overboost and then exploding basicly and with shrapnel to ruin the rest of your engine.
 
1 - 4 of 4 Posts
Top