The Diesel Garage banner

1 - 10 of 10 Posts

·
Junior Member
Joined
·
273 Posts
Discussion Starter #1
what makes a 5ek e model fuel pump go bad. i am having a issue with this one, and i think it might be the pump. is there ever a instance where sometimes it works and sometimes it dont kinda thing. i have already replace the check valve, ran great and started better than ever. sat for about a week or two went out and started it this morning, left the house, got about 10 miles down the road, hooked up my wagon. then settin there idling for about 5 minutes and started spuddering like it was running out of fuel, then died. eitherd it, started,idled like ***** for a few minutes, went about a mile down the road same thing again.done the same thing to get it goin, headed back home. dies again. bypassed the lines from the tank to the filters, changed the filters also, ran good for about 10 miles to the house, parked it.thought maybe it was the lines.went inside. came out 2 hours later, fired right up for about 5 or 10 seconds, then dies..wont start unless i either the **** out if it , which i dont like doing. anways, just wonderd if the pump will act up a few times then go bad, or will it just die.anyone had any similar experiance?
 

·
The other guy
Joined
·
3,936 Posts
what makes a 5ek e model fuel pump go bad. i am having a issue with this one, and i think it might be the pump. is there ever a instance where sometimes it works and sometimes it dont kinda thing. i have already replace the check valve, ran great and started better than ever. sat for about a week or two went out and started it this morning, left the house, got about 10 miles down the road, hooked up my wagon. then settin there idling for about 5 minutes and started spuddering like it was running out of fuel, then died. eitherd it, started,idled like ***** for a few minutes, went about a mile down the road same thing again.done the same thing to get it goin, headed back home. dies again. bypassed the lines from the tank to the filters, changed the filters also, ran good for about 10 miles to the house, parked it.thought maybe it was the lines.went inside. came out 2 hours later, fired right up for about 5 or 10 seconds, then dies..wont start unless i either the **** out if it , which i dont like doing. anways, just wonderd if the pump will act up a few times then go bad, or will it just die.anyone had any similar experiance?
I'd say algea but there is a check valve in the t-pump also... ;)
 

·
Junior Member
Joined
·
23 Posts
snowman I've had had similar problems on 2 E's mainly w/hard starting for several days or weeks and then they died while running and wouldn't start. In both cases fuel pump fixed problem easy fix and not terribly high priced. one of mine is 5ek other is 6ts. good luck
 

·
Junior Member
Joined
·
3,533 Posts
I made an adapter that I put into the line, from the primary filter to the pump, and put a vacuum gauge in the system and a fuel pressure gauge, reading the pressure then took it for a road test. With extension hoses into the cab to watch the pleasures and vacuum. In a lot of years I only had one pump of the "E" type go bad. It always ended up being something else.
 

·
Junior Member
Joined
·
273 Posts
Discussion Starter #6
I'd say algea but there is a check valve in the t-pump also... ;)
tony, would this check valve in the t- pump cause these symtoms? is there anything in the (junction box)not sure what its called, beside the primer pump, the box with all the lines on it, that needs checked also. what ever it is, it something simple....thanks for the help...
 

·
Junior Member
Joined
·
3,533 Posts
The fuel transfer pump is a very simple gear pump and it has an regulator in it. That is the hex head on the side, opposite of the outlet fitting.
 

·
Junior Member
Joined
·
273 Posts
Discussion Starter #9
well men, just wanna say many thanks for all your responses. i did change the fuel pump, and that was the problem.the new one had the allen head screw in it, and the old one had the 11/16 plug in the side, close to the front. the check valve looked pretty scored up. i would say that pump was the original and had to had over a million on it. just wanted to update on this. thanks guys:happymugs
 
1 - 10 of 10 Posts
Top