The Diesel Garage banner

1 - 17 of 17 Posts

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #1 (Edited)
Truck sucks off the jump (literally) once up to second turbo kicks in,,but remembering back this truck could spin my tires if I held the brake. These days it won't, ford put a turbo under warranty (years ago)or did they?,, anyways yesterday went into limp mode and I found a small tear on the map senser hose but I'm also feeling air leaking from the turbo clamp holes on the manifold? Is this right?
 

·
Old Fart
Joined
·
889 Posts
No. You have at least one leak in the turbo to intercooler to engine lines. All of these connections need to be air tight. There are several large hose clamps that may be leaking. Try to tighten these up and see if this solves your problem. Replace the MAP sensor hose. By the way, what are you trying to fix? Add this information to your signature by going to the USER CP.
 

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #3
I checked everything all clamps I'm going to put new ones but they all look good, except the smallest one turbo to intercooler had some fraying in it and hairline cracks so I'm replacing it. sorry it's a 2004 powerstroke 6.0, just got it running put egr delete and new oil cooler while I was in there all new gaskets, new oil coolant ect, ran good then just no power I've blown boots off before but the truck doesn't even want to shift(barely at 3300) into second and third. I replaced map hose and nothing,
 

·
Senior Member
Joined
·
1,324 Posts
I'd suggest some aftermarket boots and clamps. I like the BD ones I put on never blown a boot off since.

Dbennett is referring to your truck info in your signature. It eliminates the guessing game.
 

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #5
Thanks for the replies

All hoses look good the truck takes forever to shift also like it's not building pressure? I just put new ipr in and two days later it was junked up(screen). Put new ipr ran okay for two more days now no power, I also found oil right before the intake elbow in the hose,
 

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #6
But the turbo is leaking from the housing clamp holes why is that
 

·
Senior Member
Joined
·
3,051 Posts
  • Like
Reactions: UnderpressureNM

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #8
There's tiny holes if your looking at the Vgt solenoid there's a clamp that goes around the turbo housing it has a couple tiny holes one on each side of the turbo a little smaller than a ballpoint pen I'm getting air from those
 

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #9
{\rtf1\ansi\ansicpg1252
{\fonttbl\f0\fnil\fcharset0 HelveticaNeue;}
{\colortbl;\red255\green255\blue255;\red34\green34\blue34;}
\deftab720
\pard\pardeftab720\qc\partightenfactor0

\f0\fs30 \cf2 \expnd0\expndtw0\kerning0
\outl0\strokewidth0 \strokec2 \
}
 

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #10
If you look up [picture of Vgt solenoid on 6.0 diesel) you can see a picture by diesel power of the little holes where I'm getting air from on google search appreciate your guys help very much
 

·
Senior Member
Joined
·
1,324 Posts
Your turbo vanes may be stuck. Search cleaning 6.0 turbo there is tons of info out there. I bought the kit from International dealer (ford doesn't sell one) followed the procedure and used some premium pure nickel anti-seize I keep on the shelf. It comes with some packets but I like my stuff. That was 2 years ago.

The negative is you can over boost and damage head gaskets. Check your boost pressure.

Also if you deleted your EGR you need to get custom tuning with an SCT to correct your engine's tuning. This gets ignored often. I ran for a while without it till my cash pile replenished.
 
  • Like
Reactions: UnderpressureNM

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #12
Thank you sir for your input,,,I'm pulling the turbo now,,appreciate your guys help!!
 

·
Senior Member
Joined
·
3,051 Posts

·
Eddy
Joined
·
85 Posts
  • Like
Reactions: UnderpressureNM

·
Senior Member
Joined
·
1,324 Posts
I wish they were clearer on the anti seize note. There are different grades of anti-seize.

Use the best if your going thru the process of cleaning it.

http://www.neverseezproducts.com/purenickel.htm

I use the cheap stuff on bolts and fasteners. The pure nickel special is used for special occasions. :happymugs
 

·
Eddy
Joined
·
85 Posts
I wish they were clearer on the anti seize note. There are different grades of anti-seize.

Use the best if your going thru the process of cleaning it.

http://www.neverseezproducts.com/purenickel.htm

I use the cheap stuff on bolts and fasteners. The pure nickel special is used for special occasions. :happymugs
Im hearing to use the nickel stuff. Just a very light coating and wipe the excess off. I wish they were clearer on this subject also. Ill be pulling my turbo as soon as my parts come in from Big Bear. Going to tryout that strickly diesel compressor wheel, WW2.
 

·
Underpressure76nm
Joined
·
31 Posts
Discussion Starter #17
Took the turbo apart and it looked pretty good inside I thought it would look awful but it is a reman that ford put in under warranty awhile back, reseated it and no leaks! The housing was leaking right where the exhaust housing comes apart under the clamp,,,so I put it back and truck is running again, also I'm ordering the bd clamps and boots thanks guys for the input.:peelout
 
1 - 17 of 17 Posts
Top