The Diesel Garage banner

1 - 9 of 9 Posts

·
Junior Member
Joined
·
7 Posts
Discussion Starter #1
Hello everybody. I just bought an '83 international 1854 brush truck with a DT466 with 97k miles. It runs great and starts easy now that I put new rubber fuel lines in. My question is about the viscous fan clutch. From what I've read they're problematic. The guy i bought it from said it never overheated on him but it runs anywhere from 190*-220*. I'm getting an oil analysis done, but I'm confident the liner o-rings will hold up for at least one season.

When I turn the fan by hand with cold engine, there's quite a bit of resistance, then no resistance. It looks like its the original fan clutch from '83. During my test drive it hit almost 220 and the fan never engaged. I'm assuming that means it's bad. I've been looking for a Horton Ec450, but it doesn't look like it will bolt on. I've pressure washed the radiator, soaked it in oven cleaner and washed it out again. It wasn't very dirty- radiators get washed out on fires pretty frequently due to noxious weed spread. Any suggestions on a replacement fan clutch? Unfortunately dealer prices are pretty much out of the question. Currently I'm waiting on an infrared temp gun to test the temp drop through the radiator. IH told me it should be 12*-15* but I am doubting it's a problem with the radiator at this point. Any help would be appreciated!

Jim
 

·
Junior Member
Joined
·
93 Posts
Jim
It is probably your fan clutch. They contain a small amount of a fluid I believe liquid silicone.
It has probably leaked out over the years. I have replaced quite a few viscous fan hubs for that reason.

Terry
 

·
Junior Member
Joined
·
7 Posts
Discussion Starter #3
Thanks for the reply, Terry. Are they fixable? Did you replace them with OEM or aftermarket? From what I've read the Ht550 viscous clutch from Horton will bolt on and they're cheap but they seem to have a reputation for a high failure rate, too.

I didn't mention that this truck has a contract and Its going out on fire. My dispatch region is very hot, too. 120* is pretty normal.
 

·
Junior Member
Joined
·
93 Posts
As far as I know they are not repairable. I replaced the failed hubs with OEM because
that was what was available at the time. If an aftermarket fan hub was available
I would go with that. I have seen the OEM ones last over 10 years and had one fail
that was only a couple years old.
You might be able to get the parts to convert it to a direct drive and get rid of the
viscous hub.

Terry
 

·
Junior Member
Joined
·
7 Posts
Discussion Starter #5
Do you know who manufactured the direct drive parts? That sounds like it might be good for what I'm doing. I'm not concerned about the fuel economy as long as it keeps burning fuel!
 

·
Junior Member
Joined
·
93 Posts
Does your fan hub thread on or is it held to the drive with bolts?
You might find the parts to convert it at a wreakers.

Terry
 

·
Junior Member
Joined
·
7 Posts
Discussion Starter #7
It's bolted on with 6 bolts. I found a new replacement viscous hub on eBay, I think I'm going that route and just replace it with a new one every few years. I've been talking to another mechanic friend I know. He agreed with a new clutch being cheap it made more sense to do that. Thanks for your help, very much appreciated.

Jim
 

·
Junior Member
Joined
·
7 Posts
Discussion Starter #8
I thought I'd post an update on my thread even though it's old. I put in the new Eaton fan clutch and went for a ride up the steepest hill I could find and it boiled over and almost overheated. The boil-over is what led me to find the problem. Dang radiator cap had a nice crack in it and was not sealing. $3.50 later she was running like new. Went out on fire for a month and not a single issue :) Lol sometimes the problem is so simple it gets overlooked.
 
1 - 9 of 9 Posts
Top