The Diesel Garage banner

1 - 5 of 5 Posts

·
Junior Member
Joined
·
28 Posts
Discussion Starter #1
I have a 93 7.3idi turbo. It will start fine most the time but sometime when i go to the store or something and its sits for like 5-10 mins and i come out it won't fire. It shouldn't be the glow plugs because the truck is still hot. After it starts it runs great, i have power and everything runs good sounds good but it just will not fire sometime... it seems like it starts better when its cold then when its warmed up. Anybody know what that might be? thanks
 

·
Senior Member
Joined
·
4,827 Posts
Could be that the shutdown solenoid on the fuel injection pump going bad. They can get heat soaked and not work when they get old.

Never had it happen the the '86 I used to have, but seen it happen on others.

If it runs rough at all when it does eventually start, you could have an air leak in the fuel system. Won't always leak fuel when it happens either.
 

·
Junior Member
Joined
·
69 Posts
What bmoeller said.
 

·
spanky63
Joined
·
28 Posts
Won't Start

The reason your truck is not starting when it is warm is because your starter is dragging. Make sure your batteries are in good shape (have them tested) then pull your starter and get it tested. I had the same problem and I finally replaced the starter ow it fires like a dream. It doesn't take much drag for the engine not to turn over. But when it is already warm it has to be the starter dragging.
 

·
Junior Member
Joined
·
14 Posts
Did you get this straightened out?
 
1 - 5 of 5 Posts
Top