The Diesel Garage banner

1 - 4 of 4 Posts

·
Junior Member
Joined
·
5 Posts
Discussion Starter #1
I'm having some problems with my PSD... really the first since it was new.

It will run for a few minutes and then it just dies. Replaced the engine fuel filter and no change. I've checked the codes and there are none. I replaced the CPS since I've been carrying it around in the glove box for the last ten years and that did not change anything.

I did by the way have to change the alternator a few weeks ago but it seemed to run ok after the new alternator... no idea if that has any effect but it is charging correctly now and the batteries are ok.

Prior to the current issue a few days ago it seemed to idle rough and when driving it the throttle response was very erratic.

Any ideas?
 

·
Stuck in Commiefornia...
Joined
·
1,296 Posts
Check base fuel pressure at the filter, running. There is a test port by the fuel bowl. No codes and random stall with idle issues sounds like lack of fuel.
 

·
Member
Joined
·
48 Posts
Friend of mine had same issue, He changed high pressure oil pump and still same issue. Then he changed the fuel tank screen and fixed his problem. Hope this helps you solve yours too...
 

·
Member
Joined
·
391 Posts
I agree that first you need to be able to monitor high pressure oil and fuel to determine if either of these are the cause. There are ports in the heads that you can use to install a fuel pressure gauge. Some scanners can monitor high pressure oil. Once the truck dies, I would recommend opening up the high pressure oil reservoir and fuel bowl to check levels of both of these fluids.
 
1 - 4 of 4 Posts
Top