The Diesel Garage banner

1 - 17 of 17 Posts

·
Senior Member
Joined
·
1,415 Posts
Discussion Starter #1
I cant seem to find the suction point for the A/C system. anyone know were its at thanks.
 

·
Senior Member
Joined
·
1,415 Posts
Discussion Starter #2
never mind found it, now to meet the engineer that put it there in a back ally at night :bang
 

·
Senior Member
Joined
·
1,415 Posts
Discussion Starter #4
Its behind the air box you have to remove it to get to it. Its actually not to bad to do once you do it.
 

·
Registered
Joined
·
13 Posts
I thought it was that one. but once i connect the hose it jumps up to 70psi with the motor on and a/c full blast.


My problem is that it does not blow cold air anymore.
 

·
Junior Member
Joined
·
43 Posts
70psi is high. R134A replaced R22 and runs at a evaporator psi of 30 to 35 at a idle. A higher psi and warm air coming out may be a sign of a A/C compressor going bad.
 

·
Senior Member
Joined
·
1,700 Posts
70PSI, is bad news. go ahead and turn the blower down to low and put it in recirc/max mode and see if you can get the low side any lower. it would be much easier to offer advise if you can tell us what the high side/discharge pressure is. i would bet you high side is low too. the only thing you can do if it is, is to maybe inspect the orifice tube but more than likely the compressor is weak.

low side normals are usually between 25-35PSI.
high side normals are usually between 150-300PSI.
these pressures will vary depending on ambient temp, blower speed and which a/c selection you are using.
 

·
Registered
Joined
·
13 Posts
i just put some on my brothers honda and it went in like nothing. i am just going to take it to the dealer and see what they say. Thanks for the help guys.

ill let you guys know what was wrong.
 

·
Senior Member
Joined
·
1,415 Posts
Discussion Starter #11
what happened to mine is the line with the disharge fitting on it that goes by the intercooler tube it rubbed threw on it. so had to replace it and recharge the system, and that is on the high side mine sits at, 30 and 200.
 

·
Senior Member
Joined
·
1,700 Posts
thats a common area for rubbage and those pressures should allow nice cold air if everything else in the system is functioning normal.
 

·
Member
Joined
·
288 Posts
Mine rubbed through and I am now empty on the Freon. I am out of the basic warranty. How much was it to fix yours?
 

·
Senior Member
Joined
·
1,415 Posts
Discussion Starter #14
It is very cold and nice, Im not sure how much it was i would have to find my recite im trying to but i seem to have misplaced it. but i just bought the line and installed it myself and charged it myself.
 

·
Powerstroke Puller
Joined
·
167 Posts
make sure the compressor is even running. If the system is low and the compressor is not on, it might be around 70psi
 

·
Senior Member
Joined
·
1,415 Posts
Discussion Starter #16
70 PSI is lots to cycle the compressor on, he would see it drop off as the compressor kicked on then raise back up when it kicked off if it was low.
 

·
Registered
Joined
·
13 Posts
Hey guys well i got the truck back from the dealer and they told me that a valve on the lower side was leaking so they repaired it and recharged it. now it blows super cold cost me $172.00 with tax no warranty anymore.
 
1 - 17 of 17 Posts
Top