The Diesel Garage banner

1 - 20 of 24 Posts

·
'Ol Builder guy
Joined
·
7,051 Posts
Discussion Starter #1
Jumped in truck at noon today, fired her up and the ABS & Brake lights are on in the cluster. Checked master cylinder-full. Truck stops perfect.

What do I do now?
 

·
Gone Fishin...
Joined
·
3,099 Posts
If you shut the truck off and restart it does the light go away?
 
  • Like
Reactions: Duke

·
Junior Member
Joined
·
13 Posts
mine did that when i had bald back tires on and good ones up on the front.

it seems the computer did not like having the tires spinning at different speeds



I also got the truck to throw the same lights when i was on the dyno and had the cruise set at 65 for about 15min trying to make sure coolant was flowing after i took my radiator out once.
 

·
'Ol Builder guy
Joined
·
7,051 Posts
Discussion Starter #5
I had my tires rotated a week ago. Wonder if that set something off?
 

·
Gone Fishin...
Joined
·
3,099 Posts
Might have. In my truck, those lights come on if I am towing on slippery surfaces (snow, sand, etc..) and i'm using the 4WD. But, mine go away if I shut the truck off and turn it back on.
 
  • Like
Reactions: Duke

·
CRAZY CANUCK
Joined
·
4,320 Posts
sounds like a possible ABS sensor malfunction, is it possible that the sensors were bumped or hit by anything when the tires were rotated?
 
  • Like
Reactions: Duke

·
Gone Fishin...
Joined
·
3,099 Posts
sounds like a possible ABS sensor malfunction, is it possible that the sensors were bumped or hit by anything when the tires were rotated?
You might be on to something there. Duke, is your ABS acting up?
 

·
Banned
Joined
·
6,478 Posts
A few of our trucks had a service bulletin issues on them. Something about the abs controller under the seat getting wet. Basically what they did what cut the carpet out from around the controller so it would not hold moisture around the controller. I'm guessing this was only on the snow states.
 

·
bigdognkat
Joined
·
6 Posts
I had the same trouble and finally found out the brake light switch on the steering colomn had broken its shaft and the brake lites either stayed on or didnt lite replace the switch as per EOM specs Worked for me??
 

·
'Ol Builder guy
Joined
·
7,051 Posts
Discussion Starter #11
OK, story gets more strange. Now the warning lights are off.
I suspect they might reappear, though. They were on for ~5 days.
 

·
CRAZY CANUCK
Joined
·
4,320 Posts
it takes a while for CEL's to turn off even if the ECM doesnt detect the problem anymore it will leave the CEL on to make sure you know there is a problem, my truck did that when i blocked the EGR, it would throw a code when it tried to open the egr, the light would stay on for a while, then would shut off after a couple days and then it would try to open the egr again it would throw a code

If the CEL comes back, i would get those ABS sensors looked at, they may not be functioning properly
 

·
CRAZY CANUCK
Joined
·
4,320 Posts
:damnit hope you still have warranty on your body, thats an $1100CDN fix...... New 0mega had to get his done not too long ago
 

·
'Ol Builder guy
Joined
·
7,051 Posts
Discussion Starter #15
Nope, no warranty left on body. Took truck to dealer yesterday, they say new EBCM. However, after leaving dealer, all functions are back to normal. I think the tech pulling the harness off and reinstalling makes it work. This is the 2nd time the lights have gone off and things went back to normal. Everything is still fine today after driving around quite a bit. Common sense says I may have a corroded connector somewhere.

I looked for a used EBCM on fleabay and found a few guys who reman them for $75-$125. So if it is EBCM, it's under $200 for me to pull it, send it out to fix and reinstall. Your truck runs fine without it-just no ABS for a few days.

The thing that worries me is if it's corroded wires. A reman EBCM won't help. I have to trace the corroded wires & resolder or clean/replace, etc. :read I'd almost rather it be the EBCM and just swap out one reman part and be done with it than go looking for wires.
 

·
Pardue the Traveler
Joined
·
4,023 Posts
:damnit hope you still have warranty on your body, thats an $1100CDN fix...... New 0mega had to get his done not too long ago
I had to get the Airbag module replaced not the EBCM
 

·
CRAZY CANUCK
Joined
·
4,320 Posts
my bad :bang :damnit
 

·
Gone Fishin...
Joined
·
3,099 Posts
Maybe try an EBCM from a junkyard truck?
 

·
'Ol Builder guy
Joined
·
7,051 Posts
Discussion Starter #19
Maybe try an EBCM from a junkyard truck?

This is discouraged. I can get my EBCM rebuilt better than factory with warranty for $75-$125. However, II see no need to rebuild it it if it's working off & on. I'm inclined to believe it's a bad connection. All that said, now what do I do?
 

·
Gone Fishin...
Joined
·
3,099 Posts
First step would be to check the connectors for corrosion. If the are corroded, you can get a good idea of the rest of the wire.
 
1 - 20 of 24 Posts
Top