The Diesel Garage banner

1 - 2 of 2 Posts

·
Junior Member
Joined
·
17 Posts
Discussion Starter #1
Hi guys just thought I'd share this with anyone in case it happens to someone else I got home from work yesterday after being away for two weeks and was gonna take my 2009 6.4 for a quick drive just to give it a run after having sat for two weeks it started up fine and ran just as it always has as I pulled out of the drive way I noticed the battery light come on it had never done this before so after about a kilometer or so I pulled over shut the truck off and restarted and now the batter light was off I opened the hood and checked a few things so I kept driving after another few kilometers the battery light came on again it was then that I decieded to turn around and check the problem out more I made a few quick phone calls and after a bit of looking over the charging system found that there is a big wiring harness right beside the plug that plugs into the alternatorthe large harness had been rubbing on the three wires going into the alternator and had actually rubbed them right through, I called Ford got a replacement harness and made the repair the truck is now charging again and I made sure to tie up the large harness a little out of the way of the alternator I just thought I would share this in case anyone else is experienceing the same thing, the DTC that came up was P0620 which is generator control circuit, I have the part number for the replacement harness and will post it as soon as I have a chance.
 

·
Junior Member
Joined
·
111 Posts
Hi guys just thought I'd share this with anyone in case it happens to someone else I got home from work yesterday after being away for two weeks and was gonna take my 2009 6.4 for a quick drive just to give it a run after having sat for two weeks it started up fine and ran just as it always has as I pulled out of the drive way I noticed the battery light come on it had never done this before so after about a kilometer or so I pulled over shut the truck off and restarted and now the batter light was off I opened the hood and checked a few things so I kept driving after another few kilometers the battery light came on again it was then that I decieded to turn around and check the problem out more I made a few quick phone calls and after a bit of looking over the charging system found that there is a big wiring harness right beside the plug that plugs into the alternatorthe large harness had been rubbing on the three wires going into the alternator and had actually rubbed them right through, I called Ford got a replacement harness and made the repair the truck is now charging again and I made sure to tie up the large harness a little out of the way of the alternator I just thought I would share this in case anyone else is experienceing the same thing, the DTC that came up was P0620 which is generator control circuit, I have the part number for the replacement harness and will post it as soon as I have a chance.
My truck just did the same thing. I havent checked the harness yet but that will be first tomorrow. When it happens to mine i lose everything on the dash. lights tach heat controls raidio, but the truck still runs fine. happens intermittenly.
 
1 - 2 of 2 Posts
Top