The Diesel Garage banner

1 - 2 of 2 Posts

·
New Former Member
Joined
·
39 Posts
Discussion Starter #1
Driving back to work after lunch today and parked, looked out the side to see this dark trail of something taking the exact path of when i pulled in, and looked behind the truck and saw it was coming from my truck, so i jumped out and looked under the truck and oil was pouring out of the truck, i shut it off real fast and opened the hood and saw oil in the vally of the motor, thought it was the HP crossover line i installed had a hole rubbed in it because it was touching the y pipe, that and there was a whole bunch of oil on the ground just from idleing in one spot for like 15 sec, looked like an oil tanker rolled over in the parking lot. But no hole in it when we pulled it off so we plugged the head ports and put 10qts in it to make it touch the stick and started cranking it while we were looking to see where it was coming from and noticed it was comming from where the turbo bolts to the pedistal, went on to check the bolts just thinking for the heck of it because theres no way they came loose cause we torqed them down the specs, man was i wrong the front bolt came all the way loose and the back one was like 1/4 inch from touching! Tightend them back down but it was too late it still leaked so going to have to pull the turbo and replace the o-rings. And its funny how it all the sudden just started leaking, the bolts had to be loose for a while especially when not even touching. :shrug:
 

·
Dually Club #3
Joined
·
2,674 Posts
My X did this (not as bad) about six months after I replaced my turbo. I tightened the bolts back up and I have put 100,000 on the motor since. Don't know why though.
 
1 - 2 of 2 Posts
Top