The Diesel Garage banner

1 - 9 of 9 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
I've had a problem with the tranny surging out of OD. I was told it was an electrical thing or maybe not a good ground. Other then this it shifts fine. Any suggestions. Thanks Guys

P.S. Is this something I could fix myself
 

·
Senior Member
Joined
·
4,158 Posts
Maybe the APPS needs reset?
 

·
Registered
Joined
·
79 Posts
Discussion Starter #3
Thanks man. Not to sound dumb, but what is that?? is it something I can do or the dealership.
 

·
Senior Member
Joined
·
4,158 Posts
Well i'm not 100% positive thats whats wrong but you can try it anyway. And yes it's something you can do, Heres the instructions to it here
 

·
Senior Member
Joined
·
3,514 Posts
Yeah APPS (Accelerator Pedal Position Sensor) can cause that. Reset is simple Diesel Ram Man posted the link to the reset so that is a good place to start. See if that helps. If that works temporarily but then the problem comes back, there are more permenant fixes, usually just resetting the APPS will take care of it though.
Sean
 

·
Senior Member
Joined
·
232 Posts
Not to shoot down the apps reset for fixing the surg problem but im a mechanic at a dodge dealership and the surg problem is very common and can be fixed 99% of the time by just cleaning the battery cables and battery terminals. ive seen where some older models in the 97 yr range needed to have the altenator replaced but that problem cuases severe downshifting from 4th to 3rd sometime 4th to 2nd....
 

·
Senior Member
Joined
·
3,514 Posts
Yeah I've heard of the alternator problem, I thought that that was usually the more severe case in which reseting the APPS would only work for a day or so. DTT and some other companies make a "Noise box" or something like that that helps aid the signal from the alternator to the Neg. Battery post, and is supposed to eliminate the problem, you can also wrap that wire with copper to help it. I don't know if this is the problem he is having though.
Sean
 

·
Registered
Joined
·
1 Posts
I had the exact problem on my '01.


I went to aamco and they told me to repair it would take a total rebuild. to the tune of 3500 bucks. I am a noob to this diesel thing and to mechanics in general but I found an honest shop and they changed a sensor on my throttle body(?). I will find out exactly what it is and try and post it on here. it saved me a butt load of money though. Vancouver Transmission is the shop that helped me. In Vancouver WA
 

·
Registered
Joined
·
79 Posts
Discussion Starter #9
Edge/Fuel Pressure

Installed the Edge Juice w/ Attitude. I'm getting 13-15 psi of pressure on idle, but when driving if I push it much it drops as low as 6 psi. Is this normal? I don't want to mess up my injection pump if I can help. I hear a pusher pump may be what I need. Thanks as always Guys
 
1 - 9 of 9 Posts
Top