The Diesel Garage banner

1 - 13 of 13 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Ok, I broke down and had the truck towed to the garage today. Within an hour the mechanic called to say its got a bad Injector Control Module. He said it wasn't communicating with one side of the motor so one who bank of injectors wasn't firing. I know nothing about this part other than the basics of what it does. Can anyone enlighten me on its location and procedure for replacement.

The mechanic says he will replace the module with a new, off the shelf, modual from Ford for $880 but that includes $80 for the diagnostic. He's offered to find a used module and install it for $600 total including the diagnostic. I have no idea if these are good deal but $800 is hard to deal with right now and a used module is very scary.

How much should the module run for me to purchase. Is there an aftermarket module I should be looking at? Can I do this myself? I had the engine down to the valve covers this morning with no problems. It's not much harder than that is it?

Thanks in advance.
 

·
Rockin-S
Joined
·
215 Posts
Take it home and do it yourself, Its in the drivers fender and you can get to it by taking the inner fender loose. Then it is held in with 2 bolts. It takes a 10mm socket. Look on Ebay and buy a used one for $250 or less. Unless you just have to have it now, If you do then your gonna pay big bucks for a new. They are $750+
Walk in at Ford.
 

·
Senior Member
Joined
·
1,921 Posts
I'd be very careful about buying a used one. There is one sitting on the desk at work right now from a guy that bought one off ebay and it didn't work. Dipaco is now selling remans. They are $550 includeing at $150 core charge so once you send your core back it will only be about $400 for the part. That's WAY better than getting raped for a new one from Ford!
 

·
Git-R-Done
Joined
·
888 Posts
I would not let the guy replace the IDM so quickly. I would do a little more investigating first. If I was a betting man I would prolly guess you have a UVC harness that has come unplugged. I could be wrong about this as it is always possible the IDM took a crap on you but if UVC harness has come unplugged it will throw a IDM code.

You will need to find out which bank is showing dead and pull that valve cover and check the connection. You can also check from outside the valve cover by ohming the GP pins.

I would deffinantly go this route first just to be sure but as I said I also could be wrong.

For what it's worth, I just had a 2000 in the shop Tuesday with one dead bank and throwing a IDM code and the UVC hareness had came unplugged and that was all that was wrong with it.

Good Luck
 

·
Premium Member
Joined
·
5,220 Posts
95psdF250 said:
I would not let the guy replace the IDM so quickly. I would do a little more investigating first. If I was a betting man I would prolly guess you have a UVC harness that has come unplugged... if UVC harness has come unplugged it will throw a IDM code.

FULLY AGREED.......a couple years ago, my truck went to the shop cause it wsa running on 4 cylinders. they pulled codes, IDM showed up. they put a new one in, still did it...........looked more, and the harness under the valve cover was fried........I was ready to :nunu: :nunu: :nunu: the guys at the dealership, electrical part so I STILL had to pay for the new IDM.........total bill on that for the IDM and harness and labor was $1600............




kevin
 

·
Got Diesel?
Joined
·
824 Posts
I would've requested my old one back and threw it through their front window.

I agree with the above I've seen a whole lot of injector and IDM codes in my time, never seen a bad IDM, I know they do go bad, but not very often.
 

·
Finger Lickin GOOD!!!
Joined
·
277 Posts
In case it is the IDM, Ive got 2 used ones that I have tested myself on my truck that are for sale. Just PM me if your interested.
I also have 1 bad one that sounds Kool when its running almost like its got a HUGE cam in it LOL I call it the Add-A-Cam IDM :Thumbup:

JUst so everyone know all of the 7.3 are going out of warranty shortly so alot of the parts are going to go up in $$ believe it or not..
 

·
Rockin-S
Joined
·
215 Posts
JUst so everyone know all of the 7.3 are going out of warranty shortly
Huh? 2 years is Shortly?
 

·
Registered
Joined
·
2 Posts
I have never seen a IDM fail on one bank. When they do fail, the truck usually will not start, or it will fail for 1 or 2 injectors, not 1 bank. I would also bet that it is the UVC harness. There are clips available for the UVC harness that will keep it from coming out again if you don't want to replace the whole harness. It's better than spending $60+ for the harness itself. That is more than likely the reason it will not communicate with one bank. It doesn't see that bank because the UVC is disconnected.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #10
I spoke with the mechanic today. He used a SnapOn diagnostic that gives possible scenerios for the codes. He recieved codes related to the IDM and the CPS. He checked the GP pins for power on both sides. He said the IDM on the passenger side is passing good volts and has a steady signal. He told me the volts but I don't remember. The IDM on the right side is showing 1.3 volts that are very rough. He said he is sure the harness is connected as he could see juice running through it. Or something like that.

He also said the same thing some of you have said. He told me the IDM failing is a commom problem due to moisture. He said he has replace a few. I ask him about the offer to find a used part. He said they just get one from a wrecked truck and test it. He did recommend the new part as well. I've decided to go with a new IDM and have them install it. They come with good references, that I trust, and they said they would stick by their work.

Well see. Thanks for all the inputs. This problem had me really worried because the engine was replaced in October so it shouldn't be giving me problems. This was not an item that was replaced. tks
 

·
Ol Dirt Contractor
Joined
·
2,803 Posts
250stroker said:
I have never seen a IDM fail on one bank. When they do fail, the truck usually will not start, or it will fail for 1 or 2 injectors, not 1 bank. I would also bet that it is the UVC harness. There are clips available for the UVC harness that will keep it from coming out again if you don't want to replace the whole harness. It's better than spending $60+ for the harness itself. That is more than likely the reason it will not communicate with one bank. It doesn't see that bank because the UVC is disconnected.
What 250stroker said is right on. I keep a spare known working IDM to test with and 3 out of 3 times on 3 different trucks is was the harness or the plug.:agreed:
 

·
Junior Member
Joined
·
9 Posts
hey guys what are the symptoms of this....my truck runs really choppy and loiud at idle but goin down the highway seems to work fine?
 

·
Registered
Joined
·
1 Posts
In case it is the IDM, Ive got 2 used ones that I have tested myself on my truck that are for sale. Just PM me if your interested.
I also have 1 bad one that sounds Kool when its running almost like its got a HUGE cam in it LOL I call it the Add-A-Cam IDM 👍

JUst so everyone know all of the 7.3 are going out of warranty shortly so alot of the parts are going to go up in $$ believe it or not..
I am looking for one. Email me your info if you still have those for sale
 
1 - 13 of 13 Posts
Top