The Diesel Garage banner

1 - 13 of 13 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have a 02 2500 4x4, strait pipe, Edge pro comp and afe air intake. A few weeks ago my turbo blew. I had it rebuilt. New seals and bearings. I put it back on and it blew again in two weeks. Had rebuilt once more and now it has blown again. Any help would be very useful as to what the real problem is.
 

·
Singles Club Member #34
Joined
·
363 Posts
check and see if the oil supply line is cloged might be getting starved also try getting a new turbo maby something is out of spec on the one you keep rebuilding
 

·
Registered
Joined
·
2,224 Posts
What do you mean by blown? Oil leak? What kind of pressures does it see? EGTs?

Other than that :whs
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
blowing oil out the exhaust like crazy. egt's never over 1000. has seen 30 psi , but mostly 25 and below. this last time it is leaking oil also where the wastegate bar goes into the turbo
 

·
Singles Club Member #34
Joined
·
363 Posts
whos doing the rebuilds? is everything in spec on the rebuilt unit? when its pulled apart is there any visable damage heat or other wise to anything?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Acme Diesel in Knoxville Tn. I have not seen the turbo torn apart so I can't say. The first time it blew both sides. (compresser and exhaust) Filled the intercooler full of oil. The exhaust side of the turbo and the exhaust was caked with about 1/4 inch of gummy oil, almost like tar. The guys at Acme said that they had never seen avything like that (the amount of gummy oil) Said I might have a problem in the motor causing the turbo to blow.
 

·
Singles Club Member #34
Joined
·
363 Posts
um ok then are you putting to much oil pressure to the turbo? something goofy with your oil pump? or is the return line cloged or pluged and causing a preasure build up honestly with out looking at it i dont know but its something to check out, or who knows maby you just have a FUBAR turbo.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #9
Thanks. I'll check the oil pump. Didn't think of that. Poured oil down the return and it drained fine
 

·
Singles Club Member #34
Joined
·
363 Posts
also how long has it been since you last changed the oil and filter?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #11
Change it ever 5k. Also changed it after the 1st blow and after the 2nd. After the rebuild, drained the oil and poured about a gallon on diesel into the motor, ran about 5 minutes. Drained crap and change filter. This was to try to get out any gunk that might be in the engine. The guys at Amce said they have to do that to powerstroke alot. Don't know if that helped or hurt.
 

·
Registered
Joined
·
2,224 Posts
diesel fuel probably doesn't mix well with oil seals.

Are you 100% sure its the turbo? No oil in the exhaust manifold?
 
1 - 13 of 13 Posts
Top