The Diesel Garage banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Went to start my truck and found that the batteries were dead. 3 1/2 years old in Arizona is pretty normal. Changed out both batteries and absolutely nothing works. No dash lights, no dome lights, it is as if the batteries were not connected. My first thought was I hooked them up wrong. Double checked and they are correct. Kept looking and found that the passenger seat will move up and back and the mirrors will fold up and back out. The mirrors will not extend, doors will not lock and nothing else works. What the .....
Has anyone heard anything like this? I can't even get it out of park.
 

·
Senior Member
Joined
·
606 Posts
If nothing worked, then I would check the conections. Might want to start checking the fuse box. I assume you cleaned the conectors before you hooked the new bats.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
HAH!!! Found the culprit. I first contacted the dealer and the only tip they could provide was to bring it in for diagnostic checks. Read 2 1/2 ton of money.
Started checking everything I could think of with a DVOM. The main distribution fuse panel located under the hood had voltage to it and showed a minimal current draw and voltage drop when the passenger seat was actuated, so that in itself proved the batteries good. The inside fuse panel had no voltage and there was no main fuse or bus relay. Started checking all connections and found a large (maybe #2 AWG) with a bent lug that was not connected. When I de-termed the battery, I had to de-term one of the cables in order to get clearance to remove the battery. This cable had fallen underneath the lug connection in the exact position as if it were connected. Re-connected the cable and all is good. :stupid
 

·
TDG Mafia Member #25
Joined
·
1,447 Posts
Eh, we've all done similar type things. At least you found it yourself.

Mine is a stick, so I can't check, but all the older fords you were able to turn the key to off position and then drop down to neutral if needed.

Adrianspeeder
 
1 - 4 of 4 Posts
Top