The Diesel Garage banner

1 - 18 of 18 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
it quit working about 3 three times at one try . and now doesnt work at all what causes this? anyone? thanks kirk
 

·
Registered
Joined
·
1,592 Posts
check your fuses? if you can get codes post them. you may have a po565 to a po569?? the speed control function is integrated in the pcm. the speed control command switches are momentary switches. let us know?
 

·
Registered
Joined
·
1,592 Posts
check your fuses? if you can get codes post them. you may have a po565 to a po569?? the speed control function is integrated in the pcm. the speed control command switches are momentary switches. let us know?
 

·
Senior Member
Joined
·
1,386 Posts
check all your lights. my third brake light shorted and did the same thing to my cruise. it quit again about a month later, it turned out to be the brake switch on the front of the master cylinder. it's a 5 minute fix. when i pulled the brake switch out it was full of brake fluid. it is a dealer only item and isn't very expensive.
 

·
Registered
Joined
·
1,181 Posts
tjl said:
check all your lights. my third brake light shorted and did the same thing to my cruise. it quit again about a month later, it turned out to be the brake switch on the front of the master cylinder. it's a 5 minute fix. when i pulled the brake switch out it was full of brake fluid. it is a dealer only item and isn't very expensive.
That's a good tip along with fuses check. The first procedure the emissions service manual will direct you to follow will be a scan with a new generation Star tester. (dealer's scan tool.)
 

·
Registered
Joined
·
81 Posts
Discussion Starter #6
if the horn works cruise is getting power rite? all lights are working im going to jump brake switch on master cylinder today, dont have a way to pull codes, could i do it at advanced auto ? thanks kirk
 

·
Senior Member
Joined
·
833 Posts
no codes pulled & the freebie options :( they won't deal with the psd since it's not completely OBDII compliant.

I don't have wiring schematics to check if the cruise & horn share a power source.

you may have problems with the contacts if the other suggestions don't pan out.
 

·
Registered
Joined
·
1,592 Posts
Do you have a digital multimeter? if you do,you can pop the wheel cover off and check all the switches. if they check ok you may have a pcm problem. let us know?
 

·
Registered
Joined
·
81 Posts
Discussion Starter #9
i was going to do it this weekend but i am working six days of overtime will try tomorrow thanks for the input kirk:thanks:
 

·
Registered
Joined
·
81 Posts
Discussion Starter #10
after a couple hrs of headache trouble shooting it turned out to be the switch on the master cylinder :woot: :bow: :thanks:
 

·
Registered
Joined
·
1,181 Posts
Thanks for posting your fix. With the PCM controlled cruise sometimes all you can do are the easy checks, then try swapping parts. That's 2 brake switches in my note book and the VSS on the axle. Love it when someone beats the PCM without a code reader :woot:
 

·
Registered
Joined
·
81 Posts
Discussion Starter #12
the plot thickens i went and bought a new switch. ford part # 1L1Z-9F924-4A
Brake Repair Kit put the new unit in and doesnt work jump the plug and works any ideas? thanks kirk :barf:
 

·
Registered
Joined
·
1,592 Posts
DieselDadio said:
the plot thickens i went and bought a new switch. ford part # 1L1Z-9F924-4A
Brake Repair Kit put the new unit in and doesnt work jump the plug and works any ideas? thanks kirk :barf:
all the other tests i know of you need a scanner. is thier any way for you to get us codes to help you??
 

·
Senior Member
Joined
·
833 Posts
if you're jumping the switch and it will work then obviously the switch is the problem.

You are only bypassing one thing and when that solves the problem it becomes the part to replace to fix the truck.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #15
roger that, BJS. went and had the switch replaced today and it works wonderfully thanks for all the input folks have a great day kirk:thanks: :thanks: :thanks: :thanks: :thanks: :thanks: :woot: :Thumbup:
 

·
Registered
Joined
·
1,181 Posts
BJS said:
if you're jumping the switch and it will work then obviously the switch is the problem.
:iagree


If it was new it's a defect. At least it wasn't the F-150 type that catches fire :eek:
 

·
Registered
Joined
·
81 Posts
Discussion Starter #17
roger that
now my 6 position chip is on its way to visit Cale @ BTS for more power thanks again for all the input kirk
 

·
Senior Member
Joined
·
535 Posts
Giantpowerstrokediesels said:
: At least it wasn't the F-150 type that catches fire :eek:

haha firefighter here.... yep f-150s def catch fire just put one out last week!
 
1 - 18 of 18 Posts
Top