The Diesel Garage banner

1 - 9 of 9 Posts

·
Junior Member
Joined
·
27 Posts
Discussion Starter #1
At idle my truck has a dead mis, it smooths out under a load like A\C comp or mashin the brakes. What can this be......:shrug:
 

·
2nd Gen Guru
Joined
·
2,641 Posts

·
Member
Joined
·
57 Posts
Moparman mine does the same thing. You say check for error codes will they be there if it's not throwing a check engine light. Also talked to edge today and they told me to check the 3 banks of conectors for the injectors and spray some electrical cleaner on them. They say this is a problem that they run it alot, ever heard of this.
 

·
Junior Member
Joined
·
27 Posts
Discussion Starter #4

·
Junior Member
Joined
·
27 Posts
Discussion Starter #5
springer said:
Moparman mine does the same thing. You say check for error codes will they be there if it's not throwing a check engine light. Also talked to edge today and they told me to check the 3 banks of conectors for the injectors and spray some electrical cleaner on them. They say this is a problem that they run it alot, ever heard of this.
Thanks for the info I will try it.
 

·
2nd Gen Guru
Joined
·
2,641 Posts
springer said:
Moparman mine does the same thing. You say check for error codes will they be there if it's not throwing a check engine light. Also talked to edge today and they told me to check the 3 banks of conectors for the injectors and spray some electrical cleaner on them. They say this is a problem that they run it alot, ever heard of this.
Good idea... I tend to forget about electrical...

Electrical grimlins are the worst... I would check all lectricl connectors and clean them with contact cleaner then put a new dab of di-electric grease in the plugs again to protect them from corrosion....

Batteries... Maybe weak batteries... Or bad ground...
 

·
Junior Member
Joined
·
27 Posts
Discussion Starter #7
Mopar1973Man said:
Good idea... I tend to forget about electrical...

Electrical grimlins are the worst... I would check all lectricl connectors and clean them with contact cleaner then put a new dab of di-electric grease in the plugs again to protect them from corrosion....

Batteries... Maybe weak batteries... Or bad ground...
A local Diesel mechanic told me that it was probably a ground or the batteries. I put new batteries on it about 4 months ago. I think im gonna try cleanin the electrical parts and go from there. How would I find out if it is a bad ground
 

·
Member
Joined
·
57 Posts
Will the trouble codes be there if you dont have a check engine light. Is there a ground wire or something on the vp44 that gets dirty I thought I remember hearing something about that before,Maybe this would cause this dead mis.
 

·
Junior Member
Joined
·
27 Posts
Discussion Starter #9
The check engine light never has came on, I havent had time to check the ground wire yet ...
 
1 - 9 of 9 Posts
Top