The Diesel Garage banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi everyone! I finally traced my sluggish acceleration to the ebpv valve after unplugging it from under the turbo. Truck is very responsive now! I tried emailing Jody about this to find out if my fuel mileage is going to drop significantly while running the chip and the EBPV unplugged, but didnt get a response and dont want to bother him. Anybody know?

I already tried the whole cleaning the tube deal, I have no codes, and I dont want to buy a new sensor. Any thoughts?
 

·
Registered
Joined
·
2,154 Posts
Hi everyone! I finally traced my sluggish acceleration to the ebpv valve after unplugging it from under the turbo. Truck is very responsive now! I tried emailing Jody about this to find out if my fuel mileage is going to drop significantly while running the chip and the EBPV unplugged, but didnt get a response and dont want to bother him. Anybody know?

I already tried the whole cleaning the tube deal, I have no codes, and I dont want to buy a new sensor. Any thoughts?

I'll be happy to ask him for you and get back to you. :)


Diane
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Ok thanks Diane, let me know if I have to send this chip back to you for eliminating the ebpv. Thank you.
 

·
Registered
Joined
·
2,154 Posts
Jody said you will be fine as long as you unplugged the EBV at the turbo and left the sensor on the front plugged in. :thumbsup
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Thank you!
 
1 - 5 of 5 Posts
Top