The Diesel Garage banner

1 - 9 of 9 Posts

·
Senior Member
Joined
·
384 Posts
Discussion Starter #1
6.4L, SCT with DPF-off tune, no power increase or anything. Just dpf-free with straight pipe. Been running for around 5 years like this with no issue, no reflashes, everything has been perfect!

A couple of days ago while trying to accelerate in overdrive (enough pedal to ask for power, not enough to downshift) it started to buck / not enough power and white then black smoke came out... and it got through it. (the smoke changed to black as it was starting to provide power finally). At the next light, from a standstill, it had NO power with tons of white, then black smoke... kept on it... smoke went from white to black, and it took off... smoke cleared and launched forward like normal... The next day, went for a drive, and took off a couple of times, WOT. Everything seemed totally normal at operating temp.

Today, driving to work, still in the development, cold... light throttle (10-30%ish), NO power, tons of white smoke. Tried this a couple of times going through the neighborhood. Pulled over and let it warm up some more. Idled a little rough and not steady, cycled up and down by a hundred rpms or so in a rhythm.

Put it back in drive and tried to drive after this brief warmup... same issue, smoke, not going anywhere... pushed a little farther, the engine sound changed instantly and at that moment, the power was back after the smoke changed to black, then cleared. As it warmed up, it seemed to do it less but there is still an issue.

The strangest part is the engine sound. Grainy sound of the normal diesel engine... when it's doing this, it sounds very muffled and quiet... then when it changes, it goes back to a real / normal diesel sound, and GOES.

Does this sound like an EGR valve sticking open? The engine sound changing so obviously makes me think so.
 

·
'Ol Builder guy
Joined
·
7,051 Posts
I have similar issues. Periods of huge amounts of white smoke and an odd "hyper valve tapping" sounds. Very ugly & disturbing noise.
 

·
* * * * *
Joined
·
246 Posts
How's your killer truck, ZeroOne? Is it fixed? Hated to see this post that you're having issues with it.
 

·
Senior Member
Joined
·
750 Posts
don't sound like a egr issue to me, maybe a timing issue cam or crank sensor. or something with high pressure oil.
 

·
Junior Member
Joined
·
271 Posts
Please post when you resolve this. I have had no such problems but would sure like to no what it is in case it happens!
 

·
Senior Member
Joined
·
384 Posts
Discussion Starter #7
Better late than never....

Was in a big rush before, and today browsing, realized I never updated the thread. For anyone that runs across this in searches or whatever, wanted to post the followup. Albeit, months overdue....

Bill from Dfuser rushed me out a set of EGR block off plates, and from that moment on, it was fine. Re-tuned with SCT selecting the EGR block-off option.

Only thing I notice after long-term of having the block off in place, is that the boost numbers are a bit higher. Makes sense since all of the exhaust flow going through the turbo with no pressure bypassing through the EGR system. Nothing major though. Still on a stock fuel / dfp off tune.
 

·
Junior Member
Joined
·
16 Posts
Just curious, what tune are you running, and with the increased boost levels, is there anything that this could harm? I'm trying to trace down a very light coolant leak somewhere and was thinking that the block-off/delete might solve this problem?



Sent from my Nexus 10
 
1 - 9 of 9 Posts
Top