The Diesel Garage banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Howdy. So I installed a cold air intake last night. Drove it around tested it, sounds great great throttle response. Then this morning went out to start and warm up the truck. Check engine light was on. Code was P0401
Insufficient flow detected ERG. So I pulled the ERG thoroughly cleaned the valve itself tested its functioning o rings were good heat gasket was ok. Scraped the intake and cleaned it as good as I could vacuumed it out. Put it all back together. When I was taking the bolts out the left bolt was tightened all the way and the right bolt was completely loose. Wound up sticking a magnet in it and it came right out. Zero threads. They are stripped. Left one tightens down perfectly. Right bolt gets finger tight then spins out. Couple questions. Is not tightening down that side going to affect anything? Should I try and re thread it?
Next question. So I cleared “all dtcs “ check engine light cleared. Took it for a spin and it totally seems like I lost power. Like it’s not as responsive as it was I feel. And almost like the turbo lags until tranny shifts into second. So I pulled the EGR again made sure there was no leftover debris blew out the EGR intake by romping on it running with valve out. Replaced it all again. Still seems like it is not as responsive. I just got this truck a week or so ago and I am not sure if it had some tuning or what. It clearing all DTCS and lights would that clear other stuff in the computer I didn’t know was in there? Need some help, advice and guidance from you pros! Thanks!
 
1 - 1 of 1 Posts
Top