The Diesel Garage banner

1 - 20 of 31 Posts

·
Junior Member
Joined
·
18 Posts
Discussion Starter #1
Can anyone tell me which sensor is the EGRTA sensor? Is this a dealer item only and are there any secrets to repacing it?

My truck lost all power yesterday. It actually started out intermittenly about a week ago (meaning it would go in and out while driving). The EGT gauge would read all over the place and never seemed to read right and I am now throwing the P040D code constantly.

After doing some searches I am pretty confident that it is the EGRTA sensor and was hoping to get some info from those who may have had to change it.

I posted this in the Tuner forum because I am currently running the Spartan 210 tune. I am not sure if that is pertinant to this issue but thought I better post it in case someone else has had this issue and was caused by something else.
 

·
Chirpin Tires...
Joined
·
1,402 Posts
here is some documents i have, if you look on page 5, you will see item 7, that is the egrta, i think mick1955 may have more info on this to remove and replace it

hope this helps
 

Attachments

·
Spartan, True Performance
Joined
·
411 Posts

Attachments

·
Junior Member
Joined
·
18 Posts
Discussion Starter #5
mick, thanks for the follow up as well. You guys ever notice that when you finally get a handle on things it is Sunday and you now have to wait for Monday. The wait is going to kill me.

I hope you all have a good Mother's Day and thanks again. :thumbsup
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #6
Can you guys confirm that i have the right sensor? I just picked up part# 8C3Z-12B591-D from the dealer and the connecot type is round where the origial one is rectangular and the actual sensor portion the sits in the pipe is about 1/2 inch longer that the original. Does this sound right? And do i need to pull the pins out of the old connecter and insert in the new connector? Or did they package the wrong part in the wrong bag?
 

·
* * * * *
Joined
·
246 Posts
Can you guys confirm that i have the right sensor? I just picked up part# 8C3Z-12B591-D from the dealer and the connecot type is round where the origial one is rectangular and the actual sensor portion the sits in the pipe is about 1/2 inch longer that the original. Does this sound right? And do i need to pull the pins out of the old connecter and insert in the new connector? Or did they package the wrong part in the wrong bag?
I think the part you bought is a DPF EGT Sensor. The part number you listed is
for a DPF EGT Sensor.
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #8
So what part number am i looking for? I believe i need the EGRTA sensor. I am throwing the P040D code, have absolutely no power and the temp on the DD is not reading correctly. Either the gauge is all over the place or it reads about 200 when driving.
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #9
Just got off the phone with Ford and they said that the prope part number for the one listed in the diagram that mick attached was 8C3Z-12B591-B not (-D). I am totally confused not on which part I need.
 

·
* * * * *
Joined
·
246 Posts
Just got off the phone with Ford and they said that the prope part number for the one listed in the diagram that mick attached was 8C3Z-12B591-B not (-D). I am totally confused not on which part I need.
I would say that you need the one that ends in "B" ... the EGRTA Sensor
and not the DPF EGT Sensor that ends in "D". This is only based on
what I have read though, as I have no actual experiance with messing with
these things ...
 

·
Spartan, True Performance
Joined
·
411 Posts
Just got off the phone with Ford and they said that the prope part number for the one listed in the diagram that mick attached was 8C3Z-12B591-B not (-D). I am totally confused not on which part I need.
According to the file, they are all the same. There are 3 in the exhaust system, and one just before the turbo. Wouldn't surprise me if they changes numbers again. I'm looking at the package that I purchased from Ford, and the number is 8C3Z-12B591-D. Ask Ford what the difference is between the B, and D. Also see if you can get in touch with nordberg, I helped him, and everything worked fine.....
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #12
mick, thanks again for your input. Just to make sure I, want the one just before the turbo right? Assuming the P040D code and the incorrect temp readings via the DashDaq.
 

·
Spartan, True Performance
Joined
·
411 Posts
mick, thanks again for your input. Just to make sure I, want the one just before the turbo right? Assuming the P040D code and the incorrect temp readings via the DashDaq.
Yes, just before the turbo......

P040D - Exhaust Gas Recirculation Temperature Sensor A Circuit High - This error occurs when the EGR cooler inlet sensor temperature output value is lower (higher voltage signal) than a minimum probable temperature,
indicating an open circuit or short to power. - N > 650 rpm torque setpoint >53 N-m ECT > 60 deg C 4.65v >5sec - Wiring, Tegr_IN sensor, PCM
 

·
Member
Joined
·
163 Posts
my truck has thrown that code ever since I have got my tuner (but not because of the tuner, i was just able to read the codes with the tuner, the p040d doesn't thrown an engine light on my truck). I hope that I get the right sensor, I'm about to go to ford to pick it up. I wonder just how much that little sensor actually hurts the truck, I know I can't even run the 75hp tune anymore, the truck will barely move.
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #15
Crown Vic I hear ya. I just started throwing the codes a few weeks ago (had DD installed since June or July) with no symptoms at first but now I have the same issue that you are experiencing with absolutely no power whatsoever. The parts guy at my local dealer gave the part# of 8C3Z-12B591-B for the pre-turbo sensor. Since I have already pulled out the old one I am going to match it up when I pick it up this time. The price was $53.00 for the -B part number and $85.00 for the -D part number.

Once I get it (should be tomorrow) i'll let you know how it goes.
 

·
Member
Joined
·
163 Posts
that's when I should be getting mine as well. I already soaked the sensor in penetrating oil earlier, I'll prolly shoot one more shot up there tonight once I get home around midnight, all in hopes that it MAY loosen up a little. I've done a lot of driving along the beach and am almost 100% it will be harder to take off than the 3 were on the DPF.
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #17
Crown Vic, how did that sensor work out for you. I have not been able to pick mine up yet and was hoping to hear good news from you.
 

·
Member
Joined
·
139 Posts
i took the one out of my spare motor and it came out super easy if thats any encouragement
 

·
Junior Member
Joined
·
18 Posts
Discussion Starter #19
Sensor replaced, no more codes and all the power that I used to have. Many thanks to all who chimed in. Your knowledge was much appreciated.
 

·
Spartan, True Performance
Joined
·
411 Posts
Sensor replaced, no more codes and all the power that I used to have. Many thanks to all who chimed in. Your knowledge was much appreciated.
Now you need to tell us if there was something different with the sensors....
 
1 - 20 of 31 Posts
Top