The Diesel Garage banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
long story short...got water in fuel, wiped out injectors. replaced with rebuilt injectors, new fuel pump, and glow plugs. now with a 4" pipe and predator 85 horse program, towing a 28' boat, it has no power. the egts never go beyond 800 degrees. this wasnt the case with the original injectors. i could hit 1000 in a matter of seconds. the injectors are from real diesel. are these poorly rebuilt injectors? a little help please. thanks
 

·
Senior Member
Joined
·
2,509 Posts
Check your fuel pressurre your regulator may be stuck from some rust due to the water, and starving it for fuel.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
rust?

you know...ive posted this problem on other sites, but you are the first to suggest this. is the regulator a common problem, when water gets into fuel?
 

·
Senior Member
Joined
·
2,509 Posts
I'm just guessing. It is one of the things that I would look at, however they usually dont cause much of a problem. If you had injector issues I would think it would run ruff unless they gave you the wrong injectors or something. low fuel pressure could effect all of the cylinders in the same way causing it to have low power, low egt's, and low boost, without setting any codes.
 

·
Senior Member
Joined
·
6,337 Posts
Boost levels? Where is the pyro Probe? What kind of injectors? Any codes? age of fuel pump? What is the idle fuel pressure?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
i can run up to 35 psi. the probe is right after turbo. the injectors are rebuilt from real diesel. are the injectors junk?
 

·
Senior Member
Joined
·
2,509 Posts
1 - 8 of 8 Posts
Top