The Diesel Garage banner

1 - 20 of 20 Posts

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #1
i have an early 99 with a DP tuner, on the 100hp setting i dotn really get any smoke, if i smash it from a dead stop it will lag a little then hit and pull. on the 140 setting it does the same thing but smokes like crazy, still pulls way harder then the 100 setting. i was wondering if this is normal or if i have some kind of issue, my EGTs are 1300* goin down the 1/4m, i have a huge K&N cone filter, 22psi of boost, stock turbo back straight piped, air should be getting in and out ok, i did order a 3.5" downpipe ill see what that does when i put it in but i dont think it will do much for smoke. any input? truck ran 15.8 @ 83 :woot:
 

·
Senior Member
Joined
·
6,337 Posts
Your stock exhaust is killing you...Its smoking because there is more fuel and not enough boost... normal for a stock turbo...
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #3
will the 3.5" downpipe i bought make a big difference then? the thing smokes almost all the way down the track its crazy!
 

·
Senior Member
Joined
·
361 Posts
Get you a 4" from the turbo back. It will help with the smoke a little.
By the way......I don't know of too many trucks out there that don't smoke good when running something like a 140 or so tune.

Banks says that it is BAD for your truck to smoke.:blah: :blah:

I guess you've got a BAD truck!!!!:HappyMugs
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #5
he he he, i got a 3.5" downpipe for now so i could keep the stock 3.5" cat back (cat has been deleted and so has the muff). on the highway with the 140 setting the first half throttle the truck pulls real strong but after that u can keep putting ur foot into it and doesnt go any better, just starts smokin and the EGTs start to sky rocket, not enough air?? i was thinking of running a nitrous kit so i can take full advantage of the 140 setting, what do u guys think? power gain??
 

·
Senior Member
Joined
·
2,334 Posts
ive got an early 99 and only the 80 and 12 thinkin about adding a 140... my 120 smokes like a freight train... no lag issues tho did u get an updated ecm with it? but the 140 on a stock turbo WILLL smoke like crazy cuz stock turbos dont move nearly enough air to clear up my 120 let alone a 140 setting
 

·
Senior Member
Joined
·
2,334 Posts
the nitrus will clear it up a little bit and the hp gains will prollly be somewhat significant.. if ur egts are going through the roof like that i would look into a snows water meth first and bring those intake charge temps down..check for a boost leak only 22lbs on a 140 setting aint right i hit 25 and i should be up over 30lbs but my boots have about had it.. you need to get a 4" turbo back.
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #8
i put my 3.5" downpipe on, truck runs a lot better, a lot less lag = less smoke and more power. i think my problem was to small of a downpipe hehe had the stock one on there. i have a manual boost controller on my truck i try to keep the psi down below 24 because it sets off the SES light and i think it defuels when u get up to 24+, i could be wrong tho. definitly looking into the nitrous setup. with the 3.5" DP the EGTs climb a lot slower.
 

·
Senior Member
Joined
·
2,334 Posts
get ahold of jody or itpdiesel.com and get a boost regulator and it will keep that ses light from coming on and defueling and u can start making real boost :evil: without defueling it is a worth while investment and unlike the other kinda boost foolers the itp reg just regulates the amount of boost goin to the map unlike the other kind that actually has valves that let boost pressure bleed off... what kinda manual boost controller u have?
 

·
Senior Member
Joined
·
6,337 Posts
Could be the HPOP... The early 99's have a smaller one. that should set a code thou...
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #11
i think i found my problem, hooked up the snap on scanner tonight, on the 140 setting at wot my hpop pressure is like 1300psi, is that normal?
 

·
Registered
Joined
·
1,132 Posts
That would be it.Anything less than I think 2600 or 2700 you should set a code for icp.Like CSIPSD said early 99's have a lack luster HPOP.Go single shot inj or upgrade to a newer HPOP or dual HPOP.With the newer HPOP you will still hit max 2200 Psi in the 140.

Mike
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #13
awesome, fortunatly i have a newer hpop sitting in my garage, ill have to put it in, hopefully the truck will run better with it in there. i know bone stock my ICP pressure was only 2400psi at wot :-\. so i guess the low hpop is prob why my truck blows so much freakin smoke huh?
 

·
Senior Member
Joined
·
6,337 Posts
That would be it!!! Might look cool everynow and then but I would get sick of it after a while!!!
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #15
yeah i think thats it, i cleared the codes drove it a bit and checked em again, whatta u know "ICP pressure above or below desired". ill have to get that newer style hpop in there this week and take it back to the track. maybe itll go low 15s???
 

·
Senior Member
Joined
·
6,337 Posts
Na that HPOP will get you in the low 9's.. LOL LOL LOL LOL


Sorry, just cant help my self sometimes
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #17
well i installed the other hpop tonight, its a used reman, my dad bought it a while ago off ebay or something. anyway, the swap was easy i spent 2hrs doing it, other then getting burned from the engine being hot it was pretty easy to do. however my ICP pressure at WOT is still the same, and is actually 1100 not 1300 like i posted before, this is on the 140 setting WOT 3rd and 4th gear. the lower i turn the tuner the more the ICP pressure goes up obviously. i am seeing a gain tho, when i put my truck back to stock i noticed a couple things, it made 21psi of boost, before i could only get 18, the ICP pressure is 2600psi at wot vs 2400psi with the old pump. it def drives differently with this pump, the throttle is less snappy off idle but the more linear response is nice and it seems to run/perform better at part throttle cruise and accel. so i dunno, from posts ive read it could be my computer holding me back but then again shes an old girl with a lot of mileage so maybe its just tired. i hate situations like this, make you pick ur brain, this is where big money starts to get spent :runs and hidess::
 

·
TDG Member Since 2004?
Joined
·
584 Posts
I've heard that a lot of the reman/used pumps running around are actually 15deg. units not the newer 17 deg. ones. If you got a 15 deg. it won't help much. 140HP is too much for the stock HPOP. When the pressure drops like you say, the fuel injection pressure is around 7-9000 PSI - less than half of it's intended. The fuel essentially "pees" out of the injector in droplets rather than being vaporized resulting in lots of smoke and poor combustion.
 

·
Slow 6.0
Joined
·
1,554 Posts
Discussion Starter #19
that makes sense, thanks. ill have to look into HPOP setups after i get a good tranny to get this power to the ground :cool:
 

·
Dieselis' Maximus
Joined
·
1,744 Posts
I have popped my HPOP code on the 100 HP setting with Jody's chip so i imagine 140 is overkill especially with a stock HPOP.
 
1 - 20 of 20 Posts
Top