The Diesel Garage banner

1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
1996 7.3L SD


After reading many threads I understand that in the cold weather the EBPR will cause loss of power. Is it normal for the check engine light to come on when this happens? Light goes off when power comes back.

Thanks
 

·
Super Moderator
Joined
·
4,247 Posts
It is never "normal" to have CEL on at any time during operation.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
So in your opinion what would cause the CEL to go on? Light goes on when I exprience the loss of power but goes off when power is back.
 

·
Super Moderator
Joined
·
4,247 Posts
There is any number of things that can cause a CEL and loss of power. One is a malfunctioning EBPV.

You need to get the codes read. Active or recent codes NEED to be fixed before going on to other possible problems that may or may not, be there.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
Thank you. I'm in the process of working on these issues with my mechanic. Codes for a malfuntioning EBPV are coming up. So I'm hoping once the EBPV has been repaired the CEL issue will be solved. The only noticable symptoms are loss of power during cold engine conditions.(CEL light comes on) Once engine is warm power comes back (CEL goes off) Other threads I've read say power lose is caused by the funtioning of the EBPV, but nobody mentioned if the CEL light goes on or not, was just inquiring. I want to have as much info as possible.
 

·
Registered
Joined
·
1,870 Posts
If you have a check engine light, you have a code. What is the code?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
I don't remember the exact code from the mechanic, but he said it had to do with the EBPV. When I talk to him I will ask for the code.
 

·
Registered
Joined
·
49 Posts
This sounds like exactly the same problem I am having. But I have not had time to get it scanned yet so i don't know what the code is for yet. Hopfully I will get it scanned friday.
Does your run really rough too when the light comes on? let me know what you find out.
 

·
Registered
Joined
·
1,870 Posts
EBPV wil NOT NOT NOT NOT make it run rough.
 

·
Registered
Joined
·
49 Posts
LocoMotion said:
EBPV wil NOT NOT NOT NOT make it run rough.
Thanks, I didnt think so. But it kinda sounded the same. Mine won't even start anymore. fires a little but won't start. I will get it scanned on Friday and see what I find.
 

·
Registered
Joined
·
1,870 Posts
I bet you have a UVC harness bad. If it throws an IDM code, that's it.
 

·
Registered
Joined
·
1,181 Posts
des6120 said:
I don't remember the exact code from the mechanic, but he said it had to do with the EBPV. When I talk to him I will ask for the code.
Maybe exhaust back pressure sensor is setting the code. Clogged tube the sensor threads into will set a code and affect EBPV.
 
1 - 14 of 14 Posts
Top