The Diesel Garage banner

1 - 20 of 21 Posts

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #1
i finally got the time off to devote and setup a day for the truck and the truck only.
did the injectors, turbo, exhaust brake, and y pipes

the y pipes were fun.:squish

everything else was fine just takes time. 12 hours actually from start to finish, and thats everything, and also did a compression test on it.

but it idles rough and runs kind of rough if you dont give her some fuel, so do ya think i need to get my dp f5 chip reflashed for a different program or something?

the turbo sounds amazing, and works awesome.

the ezhuast brake doesnt work at all, really my ebpv brake worked way better, so i hope i just hooked something up wrong or soemthing. :shrug:

all in all, i'm very impressed and love the extra power and smoke. :Thumbup:

thnx guys for the all advice on how to do the install and putting up with my dumb questions.LOL

tell me what ya think about the rough idle and exhuast brake not working very good.

thnx again
 

·
Senior Member
Joined
·
2,509 Posts
how manny miles do you have on it? it may take 20 or 30 to get all the air out and make it run smooth. however single shot injectors will Idle a little rougher than your old splits.
 

·
Senior Member
Joined
·
608 Posts
please tell me you took some pictures...
 

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #4
sorry no pictures, i was working on only 2 hours of sleep and the 12 hours i spent doing it, i didnt even think about taking pictures. i will though dont worry.

but they are stage 2 split shots. not singles.

ok well i'll probably go drive it today, after my hang over has left me.LOL

and take some pics, and some vids but then i'll have to figure out how to post up the vids.

thnx guys

also do i need a boost fooler thing?
 

·
Registered
Joined
·
657 Posts
Yo congrats on being finished, if driving around to get the air out doesn't fix your problem, I would bet it's an ICP problem. Mine was doing that (rough idle/poor throttle control) seems my ICP was stuck at 3000. Replaced and runs fine. Had to replace pigtail also, guess I stretched out the prongs slipping in the 10k resistors back in the day. Crazy thing is Ford wanted 88bucks for a pigtail, International 14 bucks!

Boost fooler. I wouldn't spend the money on a prefabbed one. Just go to northern tools, lowes, HD and get a compressor regulator $20 And two 1/4" barbed fittings, two holse clamps and you're good to go (Thanks Loco)

So do you feel like you have enough oil to run those splits? Just wondering how you like them.
 

·
Registered
Joined
·
657 Posts
Also what kind of boost numbers are you getting? The waste gate comes set at 20psi and you have to take the red hose off and clamp it shut. You probably already know this but I didn't and couldn't figure how I was only makeing 20lbs:pointlaugh :pointlaugh LOL :Thumbup:
 

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #7
thnx man. did you get your sticks,turbo, and stacks on?

i'm not sure about the oil yet? might have to get a oil psi gauge.

is that what you do did for a boost fooler? can you shoot soem pics my way?
 

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #8
i'm gettign only 24 lbs.
 

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #9
also man how do i close up the red hose? and how do i close up the hole on the turbo where the red hose goes on.
 

·
Registered
Joined
·
657 Posts
I just clamped mine down in my intake hose clamp. You don't have to do anything to the wastegate, it's more or less just a valve that when you get enough pressure through the red line it opens and lets boost out,vtake red line off and it stays closed allowing you to build lots of boost.
 

·
Registered
Joined
·
657 Posts
Ihaven't taken any pics yet, but I will maybe later today. I got everything in and it hauls donkey, I can catch a third gear chirp! And I've never had so many people ask about those stacks, every truck stop I pull into I have to spend 15 minutes extra explaining the truck LOL
 

·
Registered
Joined
·
63 Posts
not to hijack or anything but i was only seeing 24lbs of boost with my setup in my sig is that right or should have i been seeing more? again sorry for the hijack and good job on the extra power
 

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #13
well if your running your stocker thats probably about right. thats all i saw b4 sticks and turbo.

i10 hauler
yea brother me too. everyone told me oh your gettin stacks thats dumb, and i said just wait and you will like them, now evryone wants to look at them and ask where i got them, so i give them darrell ophone number and let them check'em out, so now it takes longer to fuel up. LOL
wat kind of boost you seeing with your setup?
 

·
Senior Member
Joined
·
2,509 Posts
19stroker96 said:
not to hijack or anything but i was only seeing 24lbs of boost with my setup in my sig is that right or should have i been seeing more? again sorry for the hijack and good job on the extra power
in my 96 with 180cc stage 2 injectors and a wildman chip set to extream I see about 35psi. You may loose a couple of psi through the intercoller but I wouldn't think that much. You may have a bit of boost leak some where or maybe leaky exaust up pipes. also better check to see how much endplay the shaft in your turbo has.
 

·
Dieselis' Maximus
Joined
·
1,744 Posts
WHOOT congrats!!!
 

·
Registered
Joined
·
657 Posts
19stroker96 said:
not to hijack or anything but i was only seeing 24lbs of boost with my setup in my sig is that right or should have i been seeing more? again sorry for the hijack and good job on the extra power
Is it waste gated? Don't know anything about OBS trucks except they look mean:Thumbup:


so i give them darrell ophone number and let them check'em out, so now it takes longer to fuel up.
wat kind of boost you seeing with your setup?
Me too If he's reading this DARRELL PLEASE SEND STICKERS WITH PHONE NUMBER!!! LOL I've given out his number 7 times since last tuesday

And I've hit 40lbs when ICP was messed up, now that it's fixed I can get up to 35psi at WOT When you shift gears it almost sounds like a ricer blow off valve:shrug:
 

·
Hotsauce2138
Joined
·
496 Posts
Discussion Starter #17
i know man i need stickers w/ phone number too. lol

wat do i need to do to hit the numbers you are? i mean we have the same setup. LOL
 

·
Registered
Joined
·
63 Posts
pontiacross said:
in my 96 with 180cc stage 2 injectors and a wildman chip set to extream I see about 35psi. You may loose a couple of psi through the intercoller but I wouldn't think that much. You may have a bit of boost leak some where or maybe leaky exaust up pipes. also better check to see how much endplay the shaft in your turbo has.
my urbo just took a **** on me so that could have been it im getting a h2e kit sometime this week
 

·
Senior Member
Joined
·
2,509 Posts
19stroker96 said:
my urbo just took a **** on me so that could have been it im getting a h2e kit sometime this week
I think I getting very close to have to get a H2e as well. I check my oil today and it was about 1 1/2 to 2 galons low:damnit it has never used any oil before I dont have any leaks and very little blow by, I think its going out the exaust side of the turbo but not sure yet I gonna try tearing into it tomorrow. I guess these stock turbos can only take so much abuse:sly:
take a bunch of pictures of your mounting kit if you can I think I'm going to try and make my own. they want an arm and a leg for that dang kit
Is it waste gated? Don't know anything about OBS trucks except they look mean
The OBS turbos are non-wastgated
 

·
Registered
Joined
·
63 Posts
i will take pictures for ya. i was pulling my camp trailer when the turbo decided to take a **** o well i needed a bigger one anyway
 
1 - 20 of 21 Posts
Top