The Diesel Garage banner

1 - 11 of 11 Posts

·
The Phoenix
Joined
·
5 Posts
Discussion Starter #1
Last week my son said he could smell fumes. I thought he was crazy. He was right I am smelling it now. Have an appointment for next Wednesday the 22nd.

Anybody else had this issue??
 

·
Junior Member
Joined
·
36 Posts
Last week my son said he could smell fumes. I thought he was crazy. He was right I am smelling it now. Have an appointment for next Wednesday the 22nd.

Anybody else had this issue??
yes, i've seen that thread before, have you changed your fuel filter/water separator recently ?
 

·
The Phoenix
Joined
·
5 Posts
Discussion Starter #3
I have not even drained the separator yet. I have 14,500 miles. I hope it is just a clamp issue or something like that.
 

·
Junior Member
Joined
·
36 Posts
I have not even drained the separator yet. I have 14,500 miles. I hope it is just a clamp issue or something like that.
in another thread, someone had changed the water separator/fuel filter and when they reinstalled the new one the "O" ring did not seal properly and caused fumes and a small leak. i dont think there are any TSB"s out on that tho. outside of that i cant think of anyway to get fumes inside. i would think if it is strong enough to smell it inside, then maybe you could locate the source either under the truck or around and in the engine compartment.
 

·
Senior Member
Joined
·
586 Posts
My up pipe was leaking from the factory. The fumes were so bad it would burn your eyes.
 
  • Like
Reactions: jim6090

·
Banned
Joined
·
12 Posts
I think this problem is caused by the rats..... they somehows gets inside and messes with all stuff... I found a burnt rat undermy hood few days back!!!
 

·
Member
Joined
·
139 Posts
My up pipe was leaking from the factory. The fumes were so bad it would burn your eyes.
I am smelling fumes, more just after running it from start up, but really a piercing type smell.

Did you get your up pipe replaced and how did they diagnose it? Mine seems to be getting more frequent however less once the truck is fully warmed up.
 

·
The Phoenix
Joined
·
5 Posts
Discussion Starter #8
Fixed

Not sure if they replaced the pipe of tightened a clamp. It is fixed. My thought is that it did not include parts since it was fixed in a day.
 

·
Registered
Joined
·
1 Posts
I am also getting fumes in the cab. Has yours been fixed. My truck has been in the shop 7 times since I bought the truck in November for this problem and a strange whistling/sqeaking noise that happens during cold start. The techs at my dealership can not duplicate the smell, but have duplicated the sound . I dont know if the 2 problems are related.

2011 F350 6.7
 

·
Member
Joined
·
139 Posts
I am also getting fumes in the cab. Has yours been fixed. My truck has been in the shop 7 times since I bought the truck in November for this problem and a strange whistling/sqeaking noise that happens during cold start. The techs at my dealership can not duplicate the smell, but have duplicated the sound . I dont know if the 2 problems are related.

2011 F350 6.7
I havent been in yet but for next month will do it. Still getting some smell too.
 
1 - 11 of 11 Posts
Top