The Diesel Garage banner

1 - 6 of 6 Posts

·
Junior Member
Joined
·
7 Posts
Discussion Starter #1
Sent from AutoGuide.com Free App

I bought this' 04 from a guy back in the fall. He replaced the head gaskets, and head bolts with studs. "Supposedly" he replaced the injectors, which are showing a good balance now. I have had the CP3 replaced, fuel filter housing replaced, intake air heater replaced and the glow plug relay also. Today it stranded me at Wal-Mart, so I left it for 5 hours. Returned to it and it fired up after about 5 seconds. After I arrived home, I killed it twice and it fired back up easily. I'm at my wits end. Does anyone have suggestions???
 

·
Pardue the Traveler
Joined
·
4,023 Posts
okay, first I have to ask does the Security light come on when cranking? have you checked the fuel lines for cracks? was the filter in the tank ever replaced? is there algae in the tank?
 

·
Pardue the Traveler
Joined
·
4,023 Posts
is the fuel bleeder screw the nylon one? are the o rings on the filter damaged or out of place. does it crank or does it just click like a dead battery?
 

·
Junior Member
Joined
·
7 Posts
Discussion Starter #5
It cranks after awhile. The filter housing has just been replaced and the bleeder is metal. It is back in the shop and they have found a small leak between the CP3 and something, with the help of a mirror and flashlight. They are working their way to that now. It is so small, I don't think that is the big problem. However, I have been wrong once in my life, but I divorced her. :D

Sent from AutoGuide.com Free App
 

·
Pardue the Traveler
Joined
·
4,023 Posts
Glad they managed to find your air leak in the fuel line, I had to laugh at the final comment
 
1 - 6 of 6 Posts
Top