The Diesel Garage banner

1 - 8 of 8 Posts

·
Junior Member
Joined
·
52 Posts
Discussion Starter #1
Need some advice, i get a code po 674 glow plug #4 circuit failure almost ever time i start the truck.Not every time but 95% of the time it makes no difference if the truck is hot or cold.Anyone have any ideas bad glow plug,uvch,glow plug relay.Any help to point me in the right direction would be appreciated.
 

·
Junior Member
Joined
·
52 Posts
Discussion Starter #2
code po 674

Nobody has anything to offer. I guess I'll start throwing parts at it,I don't like the dealer.:confused.
 

·
Gone Fishin...
Joined
·
3,099 Posts
That year truck has the wiring harness through the valve cover correct? If so, its most likey a loose or damaged wire.
 

·
Junior Member
Joined
·
52 Posts
Discussion Starter #4
Correct Robert wiring harness through the valve cover. I'll check out wires today and see how they look. A duramax man to the rescue,thanks Robert.
 

·
Gone Fishin...
Joined
·
3,099 Posts
Correct Robert wiring harness through the valve cover. I'll check out wires today and see how they look. A duramax man to the rescue,thanks Robert.
Lover of all things diesel to be more accurate. :rock

You've got one of two things going on. The wiring is bad, or the glow plug is bad. Good luck.
 

·
Gone Fishin...
Joined
·
3,099 Posts
Any update to this?
 

·
Junior Member
Joined
·
52 Posts
Discussion Starter #7
After checking out wiring harness on both sides i found no bad wires.But I've started truck about ten times since then and no code, so I'm HAPPY so far.
 

·
Gone Fishin...
Joined
·
3,099 Posts
Nice! :thumbsup
 
1 - 8 of 8 Posts
Top