The Diesel Garage banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
yesterday my 95 powerstroke truck started fine in the morning then when i pulled out of the yard,the check engine light came on and started running rough for a few seconds then cleared up. this happend another time during the day also. then later that night the CEL came on again and the truck ran like it was running on 4 cyl now its doing it all the time.

had it towed to the garage they fixed SO THEY SAY YA RIGHT. THEY REPLACED THE PASS SIDE VALVE COVER GASKET AND WIRING HARNES UNDER THE VALVE COVER. 550.00 later

Picked it up tonight its running better but still missing engine is vibrating and low power. seems like 1 cly is not firing .

Is it safe to drive like this for the day.I have to use the truck for work .
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
The guy that fixed it has a code reader. I will have to take it back to him.

Can i run the truck like this for a couple hours like it is.

And where can i but a code reader are they expensive.?
 

·
OBS
Joined
·
403 Posts
Prolly Wal-mart. I got the edge evo, it has a code reader and clearer, then you know exactly what it is.
 

·
Senior Member
Joined
·
2,509 Posts
it may be the external harness connector that plugs into the valvecover gasket. if the gasket was burnt bad enough it may have burnt that connector a litte too, International has a repair kit but I'm not sure on the part number.
 

·
The Big Meanie
Joined
·
5,220 Posts
When my 95 did that a few years ago.....it was a bad IDM. It also threw the code for wiring harness under the valve cover. Did the Exact thing....CEL and running on 4 cylinders. I drove mine like that for a few days back and forth to town until the dealership could get it in.......




kevin
 
1 - 6 of 6 Posts
Top