The Diesel Garage banner

1 - 7 of 7 Posts

·
Junior Member
Joined
·
6 Posts
Discussion Starter #1
Hello all. I have an issue that I hope yo guys can help me with. The issue is with a 2002 Ford F250 7.3. It all started one day while driving down the road and it all of a suden just shut off just like someone shut the key off. It would not crank back up right away you have to wait about 30 to 45 minutes before it will crank back up. Once cranked up it will only run about 10 minutes then cut off again. Then the same thing you have to wait to start it back up. When its running for the 10 minutes it runs perfect no issues. This truck is my grandfathers truck and we have already had it to a mechanic who has changed the oil, changed the cps, and the pcm. None of the fixes helped so needless to say we are at square one again. Any help or suggestions on this issue would be greatly appreciated. Thanks everyone.
 

·
Member
Joined
·
391 Posts
I know you have already checked this, but is sure sounds like a cam position sensor problem. I would check the wiring harness real carefully between the CPS and the PCM and possibly swap out a known good CPS, just in case you got a bad one. Plus, I guess it could be an ICP or IPR problem. It would be nice to be able to monitor high pressure oil pressure when it dies.
 
  • Like
Reactions: Marine2147

·
Junior Member
Joined
·
6 Posts
Discussion Starter #6
Ok thank you very much. I will swap another cps and check the harness and get back with you guys. If any other ideas come to mind please send them my way.
 

·
Junior Member
Joined
·
6 Posts
Discussion Starter #7
Ok everyone. Swapped out another known good cps and nothing. I have gotten it down to the ipr or the hpop. I am going to try to rebuild and clean the one that is in there. Does this sound like a good start or should I just get a new ipr and not fool with the old one?
 
1 - 7 of 7 Posts
Top