The Diesel Garage banner

1 - 13 of 13 Posts

·
Official TDG Doctor
Joined
·
5,281 Posts
Discussion Starter #1
OK! 2001 Dodge Cummins...Right now Comp is off and SMARTY is on 7. I was pumping diesel fuel last nite, and it just shut off! did it today at idle, and twice while i was just going like 3 or 4 mph...The battery gauge will go all the way up when got on hard, but not everytime. ALSO sometimes the truck will not have any juice, so you will have to jiggle the POSITIVE connection on the DRIVERS SIDE battery...ANY HELP? It is prolly something simple, but I just need some incite!

Nathaniel
 

·
Registered
Joined
·
2,189 Posts
Bring it back to stock and see what happens.

If it acts normal...........with the chip OUT, and the Smarty......deprogrammed, or whatever, Then you got the problem pin pointed.
 

·
Premium Member
Joined
·
2,641 Posts

·
Registered
Joined
·
2,189 Posts
Ya I should have said that. Mopar MAn you should gather up every issue ever ran into with these trucks, with the bad grounds. And make a page for that too.


EDIT: If you decide to do that I scan the pages out of that issue of "Gears" that explain what all goes wrong with bad grounds in the Dodge 47RE automatics.
 

·
Official TDG Doctor
Joined
·
5,281 Posts
Discussion Starter #5
I am going to take all the Connections off tomorrow and check that and clean them for any corosion...then go from there...I PRAY thats what it is! I just didnt think that would totally shut the truck off! I hate electronics!

Nathaniel
 

·
Premium Member
Joined
·
2,641 Posts
Phily 911 said:
Ya I should have said that. Mopar MAn you should gather up every issue ever ran into with these trucks, with the bad grounds. And make a page for that too.


EDIT: If you decide to do that I scan the pages out of that issue of "Gears" that explain what all goes wrong with bad grounds in the Dodge 47RE automatics.
I might have to take you up on that... I've got to get ahold of my GF (MoparsMaiden) she does all my editing and proofreading... LOL My english suxs badly... But I think you guys get through it just fine...
 

·
Premium Member
Joined
·
2,641 Posts
HCCUMMINSSMOKE said:
I am going to take all the Connections off tomorrow and check that and clean them for any corosion...then go from there...I PRAY thats what it is! I just didnt think that would totally shut the truck off! I hate electronics!

Nathaniel
After you do clean them put a thin coat of engine oil on them and they will never corroded again EVER! My terminals look factory fresh and never been clean ever.. I just keep a coat of oil on them...:Thumbup:
 

·
Official TDG Doctor
Joined
·
5,281 Posts
Discussion Starter #8
Mopar1973Man said:
After you do clean them put a thin coat of engine oil on them and they will never corroded again EVER! My terminals look factory fresh and never been clean ever.. I just keep a coat of oil on them...:Thumbup:
Rotella T 15w40 good? Thats all we have...tractors and trucks...

Nathaniel
 

·
Registered
Joined
·
2,189 Posts
HCCUMMINSSMOKE said:
I am going to take all the Connections off tomorrow and check that and clean them for any corosion...then go from there...I PRAY thats what it is! I just didnt think that would totally shut the truck off! I hate electronics!

Nathaniel
I would buy the actual stuff for the connections and not oil. Oil works 100% times better than nothing. That is big. But the spray you can buy, has additives to deal with the corrosion that's already there. But I still use oil if I'm out of the spray.


Mopar1973Man said:
I might have to take you up on that... I've got to get ahold of my GF (MoparsMaiden) she does all my editing and proofreading... LOL My english suxs badly... But I think you guys get through it just fine...
Yep on here you have to have intelligence and a open mind. It's a forum open to the whole world. Proper grammer, english, dialect, etc. doesn't apply in such a enviroment. And people still get hammered on here for it!
Which is raw ignorance!!
It's like shouting at someone at UN meeting for not saying a word right.


I'll let ya know when I get around to scanning the pages though.......
 

·
Premium Member
Joined
·
2,641 Posts
Phily 911 said:
I would buy the actual stuff for the connections and not oil. Oil works 100% times better than nothing. That is big. But the spray you can buy, has additives to deal with the corrosion that's already there. But I still use oil if I'm out of the spray.
I tend to not use those sprays... It really does suck when you lend over the engine to clen you IAT sensor and gety RED or PURPLE gunk on you clothes every time. But the engine oil tends to wash down a bit and not get all over you...

Here are my terminals after 5 years now... Using only engine oil...:Thumbup:
 

·
Official TDG Doctor
Joined
·
5,281 Posts
Discussion Starter #12
Well my FP is fine...Im not worried about that if it fails it fails pump is under warrenty...Thanks for the concern though Andy...I took everything off, and if works fine now...thanks for all the suggestions!

Nathaniel
 
1 - 13 of 13 Posts
Top