The Diesel Garage banner

1 - 20 of 32 Posts

·
Senior Member
Joined
·
603 Posts
Discussion Starter #1
I recently bought a 2001 DRW F350 4x4 6spd with 89k on it. The truck has 4.10 gears, south bend clutch, 5" exhaust, DP tuner, intake and guages to go with it. While pulling my hunting rig (13K total load) it the truck will get pretty hot on the EGT's going up an overpass (I do tow with the cruise because it's pretty flat around here). The truck just doesn't have the power I want. I bought this truck because of the price and it will only be used on the weekends. I had two 6.0L and they will tow circles around this thing with 3.73's.

What performance parts can I get to wake this thing up?
 

·
ADMIN/MAFIA
Joined
·
4,834 Posts
What tune are you towing with? I would all DP Tuner and have see what tunes they would suggest for your application. How hot does your EGTs run? An aftermarket intercooler could possibly lower your egts some but Im not sure it would be worth the coin in return? I would start at getting the right tune for you needs and there see where you are.
 

·
Senior Member
Joined
·
603 Posts
Discussion Starter #4
EGT's sail up to 1400+ going up an overpass. Run around 950 on flat ground (while towing). Only using the 40hp mode I believe.
 

·
Senior Member
Joined
·
6,337 Posts
You have an issue somewhere...

Boost leak, drive pressure leak, turbo issue...
 

·
Junior Member
Joined
·
187 Posts
with the stuff in my sig towing is no problem. call dave at swamps about towing tuning.
 

·
Senior Member
Joined
·
603 Posts
Discussion Starter #8
Are you certain it doesn't have a boost leak somewhere? Intercooler boots look OK? Up-pipes aren't leaking?

Even towing, that sounds too hot to me.

Is your GCVWR 13K or is that just your cargo weight?

prt
I'll check more into it. I'll give it a once over tonight or tomorrow.

Thanks
 

·
Senior Member
Joined
·
603 Posts
Discussion Starter #9
I checked out the boots and I didn't see any splits but they were all oily. I might go ahead replaced them all and see if that helps.

I thought I could hear a little exhaust leak while I was towing. But I can't hear a thing while idleing. I haven't driven a 7.3l in a while so I am getting used to the sounds.
 

·
Senior Member
Joined
·
8,265 Posts
Posts have been removed that have NOTHING to do with the OP's question. Also be aware that bashing of ANY vendor won't be tolerated. Either address the question with useful real world info...not heresay or made up crap...or keep your unfounded opinions to yourself.

Thanks...
 

·
Mod Friendly Title
Joined
·
2,695 Posts
Not to sound like a dbag, but have you started with the basics... fresh oil change? Fresh air filter? Pop your intake tube off and take a look at the turbo wheel.
 

·
Senior Member
Joined
·
603 Posts
Discussion Starter #12
Yes on all three. It spools fine and runs good just ain't got enough power ya dig?
 

·
Mod Friendly Title
Joined
·
2,695 Posts
Dunno man. I've had 11K behind my truck before and while it wasn't winning any speed races, I didn't think that it was awful...
 

·
Premium Member
Joined
·
4,090 Posts
I checked out the boots and I didn't see any splits but they were all oily. I might go ahead replaced them all and see if that helps.

I thought I could hear a little exhaust leak while I was towing. But I can't hear a thing while idleing. I haven't driven a 7.3l in a while so I am getting used to the sounds.
I can't imagine hearing a small exhaust leak on these trucks.

Look for soot at the top of the up-pipes where they meet the collector (at the back of the turbo). If there's soot, it's time to replace at least the gaskets if not the up-pipes themselves.

prt
 

·
Senior Member
Joined
·
603 Posts
Discussion Starter #16
One of the 2001 7.3L's we had on the ranch had an exhaust leak on the drivers side manifold. You could not hear it at idle, but run it down the road and it was clear. Took me a bit to nail it down. It also ran hot during that time.
Kinda what this seems like. I can hear a clicking and it sounds like an exhaust leak. I'll dig more into this weekend.
 

·
Senior Member
Joined
·
603 Posts
Discussion Starter #17
I'm guessing passenger side. I can hear it about 1300rpm
 

·
Administrator
Joined
·
12,738 Posts
I'm guessing passenger side. I can hear it about 1300rpm
I bet that's what you have. My issue was started with getting the EGT's way too hot, at the time I was running a SuperChips single bank chip. I had no EGT guage for a long time, and those manifolds were probably glowing at points. LOL They warped, and the rest was history.
 

·
Junior Member
Joined
·
53 Posts
I would start with the chip. Find out for sure what tunes are on it and what tune you happen to be towing in. The 40 Tow tunes most tuners offer are pretty conservative and should not cause the high egt's you are experiencing.

Do you have a boost gauge? How much boost are you getting?

Since you tow in OD, do you think the engine is lugging and driving up the egt's? Drop it out of OD and see what happens.

I have a very hard time getting my egt's much over 900* pulling almost anything I need to.

Like was said before here, check air and fuel filters just to make sure everything is fresh.
 

·
Junior Member
Joined
·
53 Posts
Posts have been removed that have NOTHING to do with the OP's question. Also be aware that bashing of ANY vendor won't be tolerated. Either address the question with useful real world info...not heresay or made up crap...or keep your unfounded opinions to yourself.

Thanks...
I agree......it's getting pretty old. Lets leave the bashing, hearsay and made up crap up to our gummint!
 
1 - 20 of 32 Posts
Top