The Diesel Garage banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
1999 IH 4700 dump truck. Intermittent rough running, dies sometimes. ICP plug and wiring look ok. It runs ok with the ICP disconnected. I hook it back up and most of the time it continues to run ok, but sometimes the rough running returns. I'm using the truck right now, but I crank it and let it warm up and charge the batteries every 3 or days or so.
Lately it runs ok each time I've run it. I cleared the codes, and as best I remember, the only one that came back on was related to the ICP. I don't remember the code number right now. The truck is borrowed, so I need to fix it before returning it to my friend. If I had the money, I would replace both the sensor and the regulator, but I'm retired, and funds are scarce. I'm not sure my friend even wants me to "mess" with it, but I have to offer. Any, and all ideas appreciated. Glad to find this forum, thanks to all who make it possible. Gary
 

·
Junior Member
Joined
·
323 Posts
Given that it runs ok with the ICP unplugged it points in that direction.

When you unplugged it was there any oil in the connector? = failed ICP. This is how they typically fail.
Do you have a scan tool? You should see 500ish psi at idle, 750 unplugged and 1200 at full throttle in N.
If you don'thave a scanner, plug it back in and start it up. While running at idle unplug the ICP. The idle should change. If not, bad ICP.

Here are a few copy/paste part #s.
OEM Ford 7.3 ICP Part Number - F6TZ-9F838-A

International 7.3 ICP Part Number - 1807329C92

Interchangeable 7.3 ICP Part Numbers - F4TZ-9F838-A , F6TZ-9F838-A, 1807329C92, ICP102
 
1 - 2 of 2 Posts
Top