The Diesel Garage banner
1 - 7 of 7 Posts

·
Junior Member
Joined
·
28 Posts
Discussion Starter · #1 ·
I have a 03 f-350 Torqshift transmission last night I shut it off and it will not start, just clicks from the relays in the fuse box, and the glow plug light on the dash stays on for about 45 seconds.
So today I checked all fuse's and relay's and scan for codes nothing comes up.
 

·
Senior Member
Joined
·
3,051 Posts
Batteries weak, starter motor bad, charging system not working and ran down the batteries, these are some the the basics to check first. But if your glow light is staying on that long, it sounds like the batteries could be weak/discharged. Also check your battery cables/terminals for corrosion and tightness.
 

·
Registered
Joined
·
1,183 Posts
Mine did the same thing. How long has it been taking to start in the mornings? I have a '03 also and apparently the batteries are the same ones that came from the factory. For a few weeks mine had been taking longer to start in the morning but I just thought it was the cold. Then, one day, no start. The lights would come on, I could hear clicking, but nothing from the engine. I tested the batteries and the voltage was good. There was a lot of corrosion on one battery and I decided to remove the cables to clean the posts. When I put the socket on the cable to loosen the bolt, the whole post came loose with the cable. If you have another vehicle, take out your batteries and have them load tested.
 

·
Registered
Joined
·
76 Posts
Probably the batteries... especially if they are the originals. I just replaced the original batteries in mine a few months ago.
 

·
Senior Member
Joined
·
775 Posts
Check the cables and clean the cables first. Turn on head lights and ck to see if their dim and if not dim, do they dim when you try to start it. If they are dim, its batts and if they are not dim and do not dim when you try to start her, then its probably starter. The odds is a bad batt.
 

·
Senior Member
Joined
·
645 Posts
Ive had a few fried pcms do this before, you have a chip on it. most of the ones ive seen do this were due to chips like edge.
 
1 - 7 of 7 Posts
Top