The Diesel Garage banner

1 - 4 of 4 Posts

·
Junior Member
Joined
·
55 Posts
Discussion Starter #1
I'm getting a P1000 code whenever I run the 2 KEM tunes I have, Street and Tow, anyone else see this?

The only time I see P1000 is when I run the KEM tunes. I called them and basically got the definition of what the P1000 code is, which I knew, just wanted to know why.

Stock 03, egr cooler is missing but egr is in place and plugged in, no other codes.
 

·
Senior Member
Joined
·
3,051 Posts
The P1000 is for OBD2 readiness monitoring is incomplete. In other words it has not, or can not complete a drive cycle and check off all the PCM self tests. It won't hurt anything to operate this way and normally this code can be cleared or self clears after driving for awhile from a cold start to operating temps under various conditions. Whenever you load in a new tune your essentially resetting the PCM and it has to start over again and check off all the self tests.

I have no PO1000 fault code in my 03' running my KEM tuning, but the current tune has been in there for years.

Try keeping one tune loaded for awhile and operating the truck daily and see if it goes away.

Harry
 
  • Like
Reactions: jsm180

·
Junior Member
Joined
·
55 Posts
Discussion Starter #3
Thanks Harry. I've never seen the P1000 with any of my other tunes or running stock. I ran the KEM street tune for over a month and it never went away, the Tow tune throws it too. It's not a problem for me, the truck runs fine but if you live in an emissions testing state it may be a problem.
 

·
Eddy
Joined
·
85 Posts
I have KEM tunes since june 2013 and noticed that code after running a scan with my tuner. Whenever I run a code scan it shows up. When I clear the code its still there.

Kind of gave up on it over a year ago. Doesn't seem to effect the truck. But would like it gone. I've been driving in the same mode for over 6 months. Should have been enough start and stop cycles to clear it though.
 
  • Like
Reactions: jsm180
1 - 4 of 4 Posts
Top