The Diesel Garage banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 08.f250 6.4 bought it used with 50k it now has 140k
I have replaced the radiator, thermostats, turbo seals, waste gate valve and so on..

My issue is I.have oil and condesation mixture in IC , getting higher then norm boost reading in the 35 pounds and not even pulling anything, white smoke everynow and then and bad fuel mileage 12 or 13 mpg when you accelerate the turbos sound bogged down

I truly need some advice to make this truck purrr please help
 

·
Junior Member
Joined
·
30 Posts
It sounds to me like the turbos are problematic. If you have oil in the intercooler it is possibly coming from bad turbo seals. That could clog the system causing less air to reach engine and it calling for more air.

Another possibility is a torn boot connecting from the turbo to intercooler or back to engine. Again, this would reduce power and result in computer asking for more air. The air would not be making it to the engine though resulting in sluggish response. Of course, it could be a hundred other things on these complicated engines.

Keep in mind, I am not a tech or even pretend to be one on TV, so take this advice with a grain of salt. ....but I did stay at a Holiday Inn last night! :)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It sounds to me like the turbos are problematic. If you have oil in the intercooler it is possibly coming from bad turbo seals. That could clog the system causing less air to reach engine and it calling for more air.

Another possibility is a torn boot connecting from the turbo to intercooler or back to engine. Again, this would reduce power and result in computer asking for more air. The air would not be making it to the engine though resulting in sluggish response. Of course, it could be a hundred other things on these complicated engines.

Keep in mind, I am not a tech or even pretend to be one on TV, so take this advice with a grain of salt. ....but I did stay at a Holiday Inn last night! :)


I appreciate your honesty, Ihad a shop.work on it and he said he replaced the turbo seals because originally there was about a quart or more of oil in the IC. I was told this was the cause but didnt get the results due to finding a sludge in the iC oil and condensation. My alternator went out and upon replacing it I took the hot side pipe off and it was there too
 

·
Old Fart
Joined
·
889 Posts
Oil gets into the Intercooler due to the crankcase vent getting run back through the engine. You will find some oil in the IC. 30 - 35 pounds of boost tells me your boots are OK. Have you checked the EGR Valve? I didn't stay at a Holiday Inn last night...
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Oil gets into the Intercooler due to the crankcase vent getting run back through the engine. You will find some oil in the IC. 30 - 35 pounds of boost tells me your boots are OK. Have you checked the EGR Valve? I didn't stay at a Holiday Inn last night...
No I have not, no codes are popping up., but the power ratio to the boost just isnt making normal power
 
1 - 5 of 5 Posts
Top