The Diesel Garage banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Question:

I put an Edge comp box in my '98 Dodge Ram about 2 weeks ago and in the mean time I believe my lift pump has died. (Pedal to the floor, about 1800 RPM and 30 mph tops. Lucky to get up a hill. Love that power!!!)

However, it's also like the truck doesn't recognize there's a chip. The box turns on, and won't adjust, or won't turn on at all. All the connections seem to be fine.
SO, the question: Are the problems related or do I have 2 separate issues???

:damnit
 

·
Senior Member
Joined
·
313 Posts
do you have fuel pressure? i have the same thing on a 99 3500. the guy put on a comp box and in 500 miles his vp-44 pump was shot. with no fuel pressure at the vp-44 it will run intil you put start turning up the power. a comp box will make the vp-44 work hard and if there is no fuel pressure to help keep it cool it will die quick.
 

·
Senior Member
Joined
·
1,055 Posts
Is the pump wire tapped, if so make sure it is connected right or you will not have any adjustment. If you don't have f/p gauge you really need to have one. If the lift pump goes it will take the I/P will go and that is very expensive. Like they said make sure all the connections are tight.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
I'm just waiting for the injector pump to die, too....

Okay, thanks for the suggestions. I totally took the chip out and still acting as though the lift pump is out. Part gets here Thurs. However, when you take the truck out of overdrive it "freaks out", if you will. Weird up down/ updown jump in RPM's and it just flat doesn't shift out of 2nd gear. Something I'm missing that's linked here??? :damnit
 

·
Senior Member
Joined
·
1,055 Posts
Sounds stupid, but how old are your batteries. Just before I changed mine the trans acted up. Changed the batteries and it fixed the trans problem.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
The batteries are about 2 years old...Checked them both at work this morning and everything comes back fine. I'm pretty sure this all started as a result of the chip. But hey, thanks for the suggestion!
 

·
Registered
Joined
·
4 Posts
Lift Pump/Chip

My Edge Comp box has destroyed my truck. I have been through 3 carter fuel pumps, 2 holley fuel pumps, and now 2 injection pumps. I catch a lot of crap for having a dodge...all these troubles only fuel the fire:pointlaugh

Actually my truck ate the 2nd injection pump last night only 24 hours after it was put in...:damnit
 

·
Senior Member
Joined
·
706 Posts
I must be lucky,over 130,000 miles,with a drag comp on it for over 75000 of those miles,and the original vp44 works perfectly.With Vp44's,they are not all alike,there are some good ones,and some bad.IMO,the mid 99-2000 model yrs were the best vp44s made.There are a lot of good 98 Vp44's out there,but there's also some junk ones as well.Whenever i put a reman vp44 on a truck i do not tap the pump wire for at least a week,make sure it works good,and everything is ok,just run it as an EZ box,in case you have a problem ,you stil have a warranty.Tap the wire,and you own it. With the 24 trucks a fuel pressure guage should be a mandatory mod done before any fueling boxes are installed,at the minumum a pressure test should be done before any major fueling box is installed.
 
1 - 9 of 9 Posts
Top