The Diesel Garage banner

1 - 11 of 11 Posts

·
Learning to smoke
Joined
·
55 Posts
Discussion Starter #1
Friday night I was showing some of the guys and all of the sudden it reads 140 all the time??? which sensor reads that and can I buy one if needed or do I have something set wrong I recently reloaded the 250 tune because my shifts seemed sluggish.......I JUST CAN'T LEAVE THINGS ALONE!!! No codes that I can find but not reading correctly...Help?
 

·
Senior Member
Joined
·
1,415 Posts
Yes the sensor is probably toast, if i remeber its a PITA to change that one, im sure someone will have a pic of were its at.
 

·
Learning to smoke
Joined
·
55 Posts
Discussion Starter #3
That wasn't exactly what I wanted to hear (can ya soften the blow next time) Thanks.... any idea why they go bad ??? to much heat????
 

·
Senior Member
Joined
·
1,415 Posts
They just do sometimes, there just a thermocupler basically. Also with that sensor buggered your truck might start running on the weak side. It relys on the temp sensor quite abit. unless your using the 275+ tuning i beleve.
 

·
Learning to smoke
Joined
·
55 Posts
Discussion Starter #5
I did notice that it was falling off a bit.... I'm calling the ford garage to see if he can get me one...... Like to know what one it is????
 

·
Speed Junkie
Joined
·
193 Posts
I did notice that it was falling off a bit.... I'm calling the ford garage to see if he can get me one...... Like to know what one it is????
It's between the passenger exhaust manifold and the turbo. It's actually pretty easy to change out. If you take out the passenger wheel well liner, it's right there. Took me less than an hour start to finish.
 

·
Learning to smoke
Joined
·
55 Posts
Discussion Starter #7
guys the dealership tells me they can do it in ten min. and he can't find the part number you guys have listed says it has changed to an A at the end????? man I hope he's right
 

·
Speed Junkie
Joined
·
193 Posts
guys the dealership tells me they can do it in ten min. and he can't find the part number you guys have listed says it has changed to an A at the end????? man I hope he's right
part# 8C3Z-12B591-B
This is the correct part number. It was $32 from powerstrokeshop.com. Your dealer ship would have to do it in 10 minutes in front of me to believe that LOL. Not saying it can't be done, I'd just like to see it. ;)
 

·
Learning to smoke
Joined
·
55 Posts
Discussion Starter #9
TWO trips to the garage and still not fixed!!!! Now they are ordering me the whole pipe after ordering the wrong sensor twice. Not happy at all I even showed them the correct part number and they claim ford doesn't have that number???
:confused:
 

·
Speed Junkie
Joined
·
193 Posts
TWO trips to the garage and still not fixed!!!! Now they are ordering me the whole pipe after ordering the wrong sensor twice. Not happy at all I even showed them the correct part number and they claim ford doesn't have that number???
:confused:
Just order it from powerstrokeshop.com. It will get to you in about a week. Then throw it in yourself, or take it to the dealer and show them the the part number IS the right one.
 

·
Diesel Kid
Joined
·
4,580 Posts
My sensor isnt showing on my DD either. Mick said when an egrta sensor goes bad it reads 140 all the time. if it reads 0 all the time then its your software i believe.
 
1 - 11 of 11 Posts
Top