The Diesel Garage banner

1 - 9 of 9 Posts

·
Senior Member
Joined
·
459 Posts
Discussion Starter #1
All,

Anyone had an issue with low oil pressure at idle with their 6.0L??? If so, what was the culprit?? Thanks!!
 

·
Super Moderator
Joined
·
4,247 Posts
I *think* you have what is referred to as an "Idiot Gauge". Meaning that the "gauge" either reads above about 7PSI (normal) or Zero, and is NOT a true gauge that varies with changing pressure.

The "gauge" is activated by a pressure SWITCH (not sender), Ford has been doing this for 20+years on most every model.

Honestly, I am not 100% sure about the late model PSDs, but I know the earlier ones were this way (with a fake gauge).
 

·
Registered
Joined
·
1,592 Posts
you need to conferm the oil pressure first with a good gauge. it may just be a bad sensor, if the pressure is still low the low oil pump gears might be scored or wornout.
 

·
Super Moderator
Joined
·
4,247 Posts
Or the regulator is sticking. The regulator is EXTERNALLY serviceable.

There is an oil pressure test fitting below the intake just above the waterpump pulley.
 

·
Senior Member
Joined
·
459 Posts
Discussion Starter #5
Cool, thanks for your replies fellas! The oil pressure seems to come up fine by the "gauge" once the truck accelerates
 
F

·
Guest
Joined
·
0 Posts
diesel71 said:
john his truck is a 7.3 not a 6.0 so he wouldnt have the test fitting.
Good point, LOL I moved it the 7.3 Forum so wouldn't confusing anyone else...like myself LOL
 

·
Super Moderator
Joined
·
4,247 Posts
I saw the "99 Ford F250" part, but he asked about oil pressure on the 6.0L...

Anyone had an issue with low oil pressure at idle with their 6.0L??? If so, what was the culprit?? Thanks!!
This confuses me.
 

·
Senior Member
Joined
·
459 Posts
Discussion Starter #9
Yes, my truck is a 7.3L, but the truck i am taling about is a 6.0L. I am currently deployed in Kyrgyzstan and we have an 04 6.0L that has low oil pressure readings on its "guage" at idle. So, i WAS in the right forum.
 
1 - 9 of 9 Posts
Top