The Diesel Garage banner

1 - 18 of 18 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I need some help from someone who can pull codes here in the Springs or Fountain. My truck is out of business and I don't really want to spend $100 to tow it to a garage and back. I'll pick up dinner, Beer or just compensate for your time. Any help would be appreciated. Call me at 721-8695 or email me.
 

·
Premium Member
Joined
·
5,220 Posts
take a look at the 911 Emergency Member Map, I know we have alot of members out there..........good luck!!



kevin
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
Thanks. I looked but no one has signed up in Colorado Springs. If I get my truck up and running, and I don't sell it first, I'll add my name to the list. I knew I should have bought the Superchips tuner. Damn!
 

·
Senior Member
Joined
·
6,337 Posts
My brother-in-law is there, let me see if he can help you out. He doesnt know jack about his truck but I did a bunch of work on it over thanksgiving. He's got a SCT xcal2 that sholud be able to read the codes...
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
Thanks. If he can I'll compensate for his time. At the very least I'll owe him. As a countryboy that means something to me. tks
 

·
Senior Member
Joined
·
6,337 Posts
He's kind of a anti social guy but we'll see, I left a message on his cell...
 

·
Registered
Joined
·
96 Posts
Shoot, I wish I lived closer to ya. Did you ask on the club website if somebody down that way could scan it? Off the top of my head, I cannot think of anyone down that way, but if I do I will let you know.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
Yea, I've asked on the Colorado Powerstrokes and the RMFTC but no one's been able to help. I've found a garage in town I may take it too tomorrow. The mechanic says that he doesn't believe its the HPOP, at least not with what I'm telling him. I hope its not. I'm taking tomorrow off to see what I can do. I really need my truck. I have a wife and 3 kids in 3 different schools and its really difficult with one vehicle. Thanks for helping.
 

·
jammer
Joined
·
44 Posts
Hey,
I live in Castle Rock, have a Predator tuner that can scan codes. If you don't have any luck, em me and maybe I can run down on Sat am.
 

·
Senior Member
Joined
·
6,337 Posts
I built a few condos there a few years ago, nice little town almost moved there but the dang house costs!!!

My Bro in law still has not called me... dang anti social!!!
 

·
Registered
Joined
·
96 Posts
Yeah, I think most of the folks who have scanners within the club are up north here.

I've got one sitting right next to me. I wish I wasn't so busy. I feel for ya, as I've got 3 kids too.

If you get desperate and have a way to tow it, there is a great place in Ft. Lupton that can help you.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #12
Thanks for trying. You've got mail. tks
 

·
Registered
Joined
·
60 Posts
Discussion Starter #13
Well, I pulled both intercooler tubes off, pulled the AFE intake and tubing back to the turbo, unplugged all connections, cleaned all connections and inspected everything inside and out, that I could get to. I pulled one connection to the valve cover and tried to start it with no luck. I then pulled the driver's side connection and let the passenger's side plugged in and still not start. Actually it was no change at all. Still no start with a little bit of black smoke. If it were a gasoline engine I'd swear the plugs were gassed out and needed to be replaced. The engine sounds like it wants to crank but it just won't turn over. Pushing on the gas pedal while trying to start doesn't change a thing. Pressure builds up in the fuel bowl because I tried to check the filter right after an attempt to start it and the fuel was still pressurized in the bowl. It sprayed out when I finally broke the seal. There was a little oil in the boost tubes and turbo but not a lot. I cleaned the two connections to the HPOP just beside the fuel bowl and could find no leaking. All fuses have been checked and I am out of my league. :shrug:

Any last comments before I call a tow truck?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #15
The CPS that was in it was a week old. I changed it out for my spare, which is brand new. I have since put the original back in. I've pulled my chip and am now totally stock in my programming as well.

One odd note. A week ago I returned a CPS that I had just installed 3 weeks earlier because it failed, or so I thought. They replaced it with no problems and the truck ran great on my spare. Now I'm wondering if the CPS really was the problem.
 

·
Senior Member
Joined
·
6,337 Posts
On the top of the HPOP there is a cap, right hand side. Pull it and see if you have any oil in there. I'm running out of ideas but thats the next area...
 

·
Senior Member
Joined
·
6,337 Posts
Right there, where my oil pressure sender is mounted
 

Attachments

·
Registered
Joined
·
60 Posts
Discussion Starter #18
Thanks for all the reply. I broke down and had the truck towed to the garage today. Within an hour the mechanic called to say its got a bad Injector Control Module. He said it wasn't communicating with one side of the motor so one who bank of injectors wasn't firing.

I'm going to post another thread on this problem.

thanks for everything.
 
1 - 18 of 18 Posts
Top