The Diesel Garage banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
(rough start/idle, white smoke) i know why mine is running bad. passed a transport on the way home and got a soft code, engine light. went out and seemed to run ok the rest of the way home..but next day truck seemed to have some issues...rough start-up and idle and lots of white smoke....there was always a little on start up but never this much..truck is stock 02 f350 xl work truck (2wd super cab long box) 430,000 km (i know its high) i bought a diablosport predator u7170..put on 60 hp economy tune, ran fine except i think i was on the throttle too long, accelerated hard to pass a transport and another car in front of it......it was due for oil change too but wanted to diagnose a leak on top first..i think from the hpop... now it definitely needs new oil because it is a little low and dirty... any help is appreciated...should i change the oil before i even try to start it again? i am just really worried that i have damaged something... maybe i shouldn't have been so hard on it? ...could it be just an injector gone or the over-volatage caused some sensor to meltdown? am hoping its not engine damage... also where is the icp and how to disconnect to check it? also how to buzz test injectors..
 

·
Registered
Joined
·
300 Posts
What does the smoke smell like? Fuel? Sounds like an injector issue. . .would be extremely probable with 400k+ miles on the injectors.
 

·
Junior Member
Joined
·
15 Posts
pull the codes it will give you the first set from the programmer sets off then it will give the real codes I just had this happen last week ran into the store to grab something. When I came out all I could smell was diesel and the truck was running like **** and smoking like a train (white smoke). Long story short it was the wiring harness and the UCVH gasket were melted but when I first remove the valve cover it looked normal until I unplugged it. Changed it out with a older set I had from doing the drivers side last year.Fired back up and runs like a charm again. But the programmer will only give you a P1316 code which is codes stored in the IDM. Good luck
 
1 - 4 of 4 Posts
Top