The Diesel Garage banner

1 - 4 of 4 Posts

·
Junior Member
Joined
·
3 Posts
Discussion Starter #1
Ok so about 3 weeks ago my 7.3 idi 2X4 auto just stopped running and would not start at all. I got a diesel mechanic to look at it and he said the IP was bad and so i took it to a reliable diesel shop locally to have them rebuild it. After the mechanic installed the rebuilt IP the truck was hard to start and ran about 5 min and died. Today i tried to start it and it started 2 times and it ran for 1 to 2 min tops each time and had white smoke out the exhaust. Any ideas on whats going on? Oh and the truck use to start first time no problems warm or cold prior to the truck dieing on me 3 weeks ago. Any help or suggestions i am thankful for.
 

·
1abmechanic
Joined
·
5 Posts
White smoke is a usely unburned diesel fuel, But it could be coolant. Does it smell like fuel? If it does then I would check the glow plugs, Are they good?
Is the fuel filter getting fuel? If it is loosen a fuel line a one of the injectors, chank the engine and see if fuel is there. If all of the above check out the IP could be out of time. I don't know how to check that. Why isn't the mechanic who told you the IP was bad fixing it?
 

·
Junior Member
Joined
·
3 Posts
Discussion Starter #3
I have fuel to the filter and IP. The truck does not burn coolant, so im guessing it was unburnt fuel. I will get new glow plugs tomorrow from advanced auto parts bec from what they say they carry the oem mc plugs for the truck. I just don't understand why the glow plugs would all the sudden be such a problem now, but hey it wouldn't hurt to change them anyways. Thanks
 

·
03 f350 xl 7.3 2wd x-tend
Joined
·
119 Posts
Hey if it were glow plugs wouldn't the white smoke clear up once the truck is warmed up? Because they only help warm things up on cold starts, not once your up and running.
 
1 - 4 of 4 Posts
Top