The Diesel Garage banner

1 - 8 of 8 Posts

·
Junior Member
Joined
·
6 Posts
Discussion Starter #1
I have a 06 duramax with 65,000 miles.When the thermostats heat up and open it starts a weird noise at the the tube coming out of the bottom of the thermostat housing.It does not make it untill they heat up and open.Does anyone else have this problem and is ther a fix?:swear
 

·
CRAZY CANUCK
Joined
·
4,320 Posts
im not entirely sure i understand what you mean, what kind of noise is it, and how do you know that its when the thermostats open? those thermostats open at different temperatures as well..... you mean the tube going to the water pump? :shrugs
 

·
Junior Member
Joined
·
6 Posts
Discussion Starter #3
I watched the temp when i narrowed down where the noise was coming from.It starts at about 90 degrees or so.It sounds like a sucking sound.The tube is on the front of housing directly under the front thermostat going down to the bottom drivers side of the motor.
 

·
CRAZY CANUCK
Joined
·
4,320 Posts
does your upper rad hose stay hard over night? i mean you cannot squeeze it at all hard...

sounds like you are having air in your coolant system
 

·
Junior Member
Joined
·
6 Posts
Discussion Starter #5 (Edited)
I dont know if it stays hard or not.I will check it in the morning.I do know I can take the cap off the overflow tank and loosen the screw on top of the thermostat housing and it does not make any difference in the noise but if you turn the truck off and let it cool just enough for the thermostats to close the noise goes away untill it warm back up.I thought the thermostats may not be operating right and causing a gurgling or sucking sound.
 

·
CRAZY CANUCK
Joined
·
4,320 Posts
I noticed that sound, but it was when i was diagnosing my blown head gaskets, i havn't bothered to listen for the sound since
 

·
BUG JUICER and
Joined
·
1,239 Posts
The tube you refer to is the recirc or bypass tube, it runs to the water pump. Only one of the thermostats, the bypass stat, serves it. The thing is, unless you are pulling a load, that stat is staying closed in this weather. I am guessing you may have debris in the low temp thermostat.
 

·
Junior Member
Joined
·
6 Posts
Discussion Starter #8
I put 2 new stats in yesterday still does it.Stealership mechanic says it is fuel pump rattle and is normal wear.I think its a bunch of bull.
 
1 - 8 of 8 Posts
Top