The Diesel Garage banner

1 - 16 of 16 Posts

·
Member
Joined
·
142 Posts
Discussion Starter #1
Pulling 10K 5th wheel camper through the smokey mountains with 210, egts never got above 1200 boost never got above 35 now the bad part. 130 Miles on half tank of FUEL lom showed 9.3, truck ran hot- oil temp high, fuel rail temp high, trans temp high, truck started defueling, pulled over radiator was boiling over. service engine light came on codes showed mil status off, P048 fan 1 control circuit, p0528 fan speed sensor circuit ,p2263 turbo super charge boost system performance. Does anyone know if the codes are tuner related or is it a hardware problem and the fan has gone out?
 

·
Senior Member
Joined
·
2,183 Posts
maybe be the radiator or high elevation? just guesses though
 

·
Junior Member
Joined
·
138 Posts
Judging by the 2 fan codes I would say the fan system wasnt working right and thats why it was running hot.... The other things could be another underlying problem or maybe just secondary issues due to overheating.

That would be my guess, I would make sure the fan and temp sensors where working correctly First.
 

·
I Eat Rice
Joined
·
2,155 Posts
where did you boil over and what was your coolant temp. I just got a new degas bottle to fix my puking problem. I pulled my 15k trailer with all the snow and ice on the roof more like 17k. Up some monster steep 2-3mile long hills and lost about half a gallon. The truck is stock right now. coolant temp hit 216 and oil was at 220. Nothing out of the top of the degas though.
 

·
Member
Joined
·
142 Posts
Discussion Starter #5
Coolant was boiling out of the bottle, coolant hit 235, oil temp 232, fuel rail temp was also hot don't rembember the temp. Most of this happened on an 8% grade about 2 miles long.
 

·
Member
Joined
·
142 Posts
Discussion Starter #6
Well I tried to take the truck in to an unknown dealer when i was out of state, he was not mad friendly at all (I have a complete 5" exaust system, I don't carry the factory system with me to swap out in case of problems, wish I would have stayed with the dpf delete only for this reason) I was straight up with the dealer and told him what all I had on the truck and it had been programed back to stock. He hadn't heard of Spartan, he asked if it was like the bullydog. I explained it to him as a dpf delete product. He would not even look at the truck without the DPF on, he said his equipment couldn't get past the code for the DPF being gone. He also said that my warranty (engine and transmission) would be voided because of the mods, he said he had 1 in his shop with the Bullydog that had voided the warranty. I asked him how my local dealership can check out my truck without the DPF? He said that Spartan must have paid them off and got some test equipment. Needless to say I didn't leave my truck with him (after i drove a hour to get there) I tuned the truck down to the 75 tune and pulled the camper back home. The cooling fan is still out and had to do alot of coasting and stopping for cooldowns, but made it haome and will take it to my dealer next week.
 

·
Junior Member
Joined
·
124 Posts
Well I tried to take the truck in to an unknown dealer when i was out of state, he was not mad friendly at all (I have a complete 5" exaust system, I don't carry the factory system with me to swap out in case of problems, wish I would have stayed with the dpf delete only for this reason) I was straight up with the dealer and told him what all I had on the truck and it had been programed back to stock. He hadn't heard of Spartan, he asked if it was like the bullydog. I explained it to him as a dpf delete product. He would not even look at the truck without the DPF on, he said his equipment couldn't get past the code for the DPF being gone. He also said that my warranty (engine and transmission) would be voided because of the mods, he said he had 1 in his shop with the Bullydog that had voided the warranty. I asked him how my local dealership can check out my truck without the DPF? He said that Spartan must have paid them off and got some test equipment. Needless to say I didn't leave my truck with him (after i drove a hour to get there) I tuned the truck down to the 75 tune and pulled the camper back home. The cooling fan is still out and had to do alot of coasting and stopping for cooldowns, but made it haome and will take it to my dealer next week.
Sorry to hear about your luck, and the run in with the dealer. You're definitely at a disadvantage when you're on the road with camper and all; hopefully better luck with the local dealer.

Keep us updated. Camping season in Michigan is about ready to start, and I'm intending to pull some moderate grades in the Northern part of the state with 12,500lb running the 210hp tune. :happymugs
 

·
Registered
Joined
·
59 Posts
I asked him how my local dealership can check out my truck without the DPF? He said that Spartan must have paid them off and got some test equipment.QUOTE]

WTF is that *****. That dealership is on crack.
 

·
Powered By Ford
Joined
·
2,438 Posts

·
Member
Joined
·
142 Posts
Discussion Starter #11

·
Member
Joined
·
142 Posts
Discussion Starter #13
I dont know if the fan is bad or just a sensor, I'm taking it in this week
 

·
Senior Member
Joined
·
370 Posts
I'm going thru the same garbage. My truck doesn't boil over or get hot but when I tow 17-18k the 175 tune defuels the truck to stock and will not turn back on until the truck is shut off and restarted. The oil and water temp runs within 5 degrees of one another. They never get over 210. The egt's never have passed 1250. I don't know what the f$%k is wrong with it and why it does it. I've called matt and got an instant phone call back with what to monitor. Called back again to reconverse and haven't heard back for 2 weeks.
 

·
Member
Joined
·
142 Posts
Discussion Starter #15
Finally took it in to my local dealership today(1st thing my service tech asked me was how I liked the new 5" exhaust and what kind of milage was I getting with the tuner:wink[3]:) anyway he found the problem- can you believe the last time the truck was in for replacing the idler pulley on of the techs forgot to plug in the fan :doh: He said he cleared the codes but when I scanned with the DD they were still there, was it just saved on the dashdaq? can I clear them now?
 

·
Spartan, True Performance
Joined
·
411 Posts
I would clear them!!!!! Think you will remember if you see them again..
 
1 - 16 of 16 Posts
Top