The Diesel Garage banner

1 - 6 of 6 Posts

·
Junior Member
Joined
·
6 Posts
Discussion Starter #1
Has anyone had any problems with there slide-out. It seems like mine is off track sometimes. The slide will work sometimes. It will slideout and wont slide in. Sometimes it works fine and sometimes it doesn't.. Sometimes is it want slide at all. I have taken the carpet loose to look at the motor and gearbox. I haven't had much luck in plain view. It almost seems like a gear slipping and not grabbin at all sometimes. It just started doing this. When pulling and going around a sharp turn, the slide will slide out a little bit. Anyone had any experiences like this.

We have a 2003 Keystone Outback 30ft Travel Trailer
 

·
Junior Member
Joined
·
75 Posts
You might have better luck calling Keystone and seeing what their tech guys say. I have an Excel and have had great luck talking to those guys when I have issues.
 

·
ADMIN/MAFIA
Joined
·
4,834 Posts
Have you ever lubed the track under the slide out? there are adjustments for them on the underside I believe. Keystone would be my first call as well.
 

·
Senior Member
Joined
·
776 Posts
I have an '07 KZ New Vision Sportster.....My motors are mounted under the slide out itself. I broke a mount on mine and replaced it. Mine has a drive rod that spins a gear on each end of the slide out to ensure that the slide out comes out evenly. If you have one of those, it may be just a bolt loose. Check the mount bolts on the motor as well as any other bolts....that lsiding out while going around a corner is not good.....also, do you block your slide outs? My toyhauler came with telescoping rods that keep the slide outs from sliding out in case of motor or any other type of failure...
 

·
Inline Junky!
Joined
·
1,705 Posts
Has anyone had any problems with there slide-out. It seems like mine is off track sometimes. The slide will work sometimes. It will slideout and wont slide in. Sometimes it works fine and sometimes it doesn't.. Sometimes is it want slide at all. I have taken the carpet loose to look at the motor and gearbox. I haven't had much luck in plain view. It almost seems like a gear slipping and not grabbin at all sometimes. It just started doing this. When pulling and going around a sharp turn, the slide will slide out a little bit. Anyone had any experiences like this.

We have a 2003 Keystone Outback 30ft Travel Trailer

Can you tell if you slide is gear driven or hydraulic driven? IIRC Keystone uses a hydra driven slide out on there big stuff. Which is made by lippert frame corp. If that's the case it might be low on fluid. If its gear driven you have a chipped tooth on the main drive gear.
 

·
Junior Member
Joined
·
6 Posts
Discussion Starter #6
Thanks for the input..... It is electrical lippert system.. It appears that the motor didn't have enough bolts in the shaft that mounts to the rod that controls the slide to go in and out. The pressure of the bolts is used for a braking system for this unit. It has a brass bushin and that appears help. The cause for the slipping is because it had only one bolt in it and the pressure caused it to back out.....
 
1 - 6 of 6 Posts
Top