The Diesel Garage banner

1 - 10 of 10 Posts

·
Senior Member
Joined
·
622 Posts
Discussion Starter #1 (Edited)
My mods are listed in my signature and here is what i know. @ 1660 rpm my injection pressure is 9.3 Mpa (1350 psi) this is really low, especially with the HPOP i have installed, TCC has 0% slip and icp voltage is 1.81v can this be changed with tuning? my injectors have about 17000 miles on them, and the pump has about 6000 on it.

I got my information using my OTC nemisys scanner.
 

·
Senior Member
Joined
·
862 Posts
Sorry to tell you this, but 1350 psi at 1660 rpm tells us absolutely nothing. Reason being is that the high oil pressure is not based entirely on RPM's. Throttle position, engine load, tuning, etc will determine what your oil pressure is (or should be), and it's up to the pump to supply the oil demanded.

1350 psi at 1660 rpm is completely normal, especially if you are cruising and not putting a load on the engine. That's probably all the tuning is calling for anyway, so the rest is going to bleed out via the IPR.

The two things we can tell over the internet regarding oil pressure is 1) idle, and 2) WOT full blast. At idle, your oil pressure should be around 500 or so PSI (slightly above or below is fine, as long as the truck idles fine). At WOT and with your pump setup, your oil pressure should try to maintain close to 2800-3000 psi on either stock tuning, or even with your TS chip on any setting.
 

·
Senior Member
Joined
·
622 Posts
Discussion Starter #3 (Edited)
that number was obtained merging into traffic excellerating up a 2% grade with overdrive off and the TC locked TP was 30%. either way there should be more icp under this condition.


pocket, I know where the the oil oressure should be, my question was, do the tuners think it is my current tune or should i look into gettting new ones... i dont need and education on specs.
 

·
Senior Member
Joined
·
622 Posts
Discussion Starter #4 (Edited)
My mods are listed in my signature and here is what i know. @ 1660 rpm my injection pressure is 9.3 Mpa (1350 psi) this is really low, especially with the HPOP i have installed, TCC has 0% slip and icp voltage is 1.81v can this be changed with tuning? my injectors have about 17000 miles on them, and the pump has about 6000 on it.

I got my information using my OTC nemisys scanner.
Edit: all i want to know is can more icp be obtained with new tunes with out advancing timing? I dont want or need more power, i just want to decrease the black smoke and if possible fix how overdrive feels really sluggish when excellerating. sorry for the confusion in the first post i was getting really tired.
 

·
Senior Member
Joined
·
862 Posts
Sorry for the "education", but your added posts filled in the blanks on the missing info.

To answer your question, yes ICP at lower RPM's can be raised with tuning. In addition, timing can be adjusted if/when necessary. Your fueling will have to be adjusted, as you'll shoot more fuel in if you raise ICP yet keep the pulsewidth the same. At lower RPM's, you'll overfuel and throw out a larger cloud of black smoke.

Now the real issues is.... will that fix your black smoke issue and sluggishness in overdrive or at lower RPM's? Just wondering, since I see in your sig a TN replacement turbo. Is that the JB or the BB version you are running? I've driven a truck with the JB version, and it was super laggy on the bottom end. If you also have the JB version, that might be part of the problem too. Just something to consider.
 

·
MAFIA MEMBER 106
Joined
·
2,262 Posts
have you tested the hpop? i have heard of some hot start and low icp from the setelth stg 1 and 2
 

·
Junior Member
Joined
·
55 Posts
this might sound dumb, but it could just be your TS chip. theres alot of people who can't run a TS on there 7.3l for some reason. I tried using TS on my truck and had nothing but trouble with it and even the tunes such as hidle idle wouldn't work correctly, I tried 3 differnt TS chips and ended up sending them my pcm to be reflashed. So i went with a DP tuner and its been fine ever since
 

·
Senior Member
Joined
·
622 Posts
Discussion Starter #8
i have never experienced any trouble with my chip, i know my pump has more in it and i have not had hot starts it works pretty good, I have sent my chip to swamps to get new tunes put on it so I will see what they come up with.
 

·
Junior Member
Joined
·
78 Posts
Dp tuner

this might sound dumb, but it could just be your ts chip. Theres alot of people who can't run a ts on there 7.3l for some reason. I tried using ts on my truck and had nothing but trouble with it and even the tunes such as hidle idle wouldn't work correctly, i tried 3 differnt ts chips and ended up sending them my pcm to be reflashed. So i went with a dp tuner and its been fine ever since
amen to that !!!
 
1 - 10 of 10 Posts
Top