The Diesel Garage banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
AKA slowdog racing
Joined
·
925 Posts
Discussion Starter #1
i didnt notice this till the other day when it started raining but i think it has been goin on for the last couple weeks....the other day at Taco Bell i had a hard time turning in the drive threw.....well then i started noticing every time i was making a sharp turn that my inside tire would start hopping :damnit so i was wondering if anyone has heard of the stock difs locking on GMs before cuz i dont think ive read about it in any of the forums.

:popcorn:
 

·
Registered
Joined
·
155 Posts
maddogg1019 said:
i didnt notice this till the other day when it started raining but i think it has been goin on for the last couple weeks....the other day at Taco Bell i had a hard time turning in the drive threw.....well then i started noticing every time i was making a sharp turn that my inside tire would start hopping :damnit so i was wondering if anyone has heard of the stock difs locking on GMs before cuz i dont think ive read about it in any of the forums.

:popcorn:
Yeah... heard about that. A friend of mine has A 00 gasser with a 5.3L doing that exact same thing. The only way to unlock the rear end was to back up and turning left or right, can't remember. Looks like you gotta get your G80 looked at.
 

·
Registered
Joined
·
1,585 Posts
goto dealership and purchase one bottle of limited slip additive and put in the rear end and that should free it up
 

·
AKA slowdog racing
Joined
·
925 Posts
Discussion Starter #4
im goin outside and changing the fluid and seein if theres anything wrong with it....ill post back up later....thanks for the help.

:popcorn:
 

·
IS FREE!!!!!
Joined
·
1,143 Posts
limited slip additives have to be added with an empty housing, then fill the rest of the way with fluid. good luck curtis. u might need it bud
 

·
Mafia member #105
Joined
·
2,262 Posts
When changing your fluid Curtis, Use the Gm fluided and you dont use a additive its already in the fluid.
 

·
AKA slowdog racing
Joined
·
925 Posts
Discussion Starter #7
ok went outside and changed the fluid but its still locked
 

·
Senior Member
Joined
·
3,939 Posts
I think you have a problem with the spider gears/springs in the carrier. Only way to know is to pull the cover and look.

(or did a buddy secretly install a Merchant mini-spool and not tell you???)
 

·
Registered
Joined
·
155 Posts
maddogg1019 said:
ok went outside and changed the fluid but its still locked
I thought so, that only a fluid change wouldn't help. Didn't help on my friends truck either. He ended up swapping the G80 with a different locker.
 

·
AKA slowdog racing
Joined
·
925 Posts
Discussion Starter #10
TheBac said:
I think you have a problem with the spider gears/springs in the carrier. Only way to know is to pull the cover and look.

(or did a buddy secretly install a Merchant mini-spool and not tell you???)
i wish LOL i pulled the cover and everything looked good put it was dark out and i was using a flashlight.
 

·
AKA slowdog racing
Joined
·
925 Posts
Discussion Starter #13
ok now it unlocks when it wants but is still locking when it shouldnt but atleast its not locked 100% of the time like it was for the last week.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top