The Diesel Garage banner

1 - 19 of 19 Posts

·
Senior Member
Joined
·
567 Posts
Discussion Starter #1
My bronco seems to run warm. It used to run a little warm in the truck too but i still havent figured out why.


Its a 1994 factory turbo, all alumn radiator, intercooled, 190* thermostat, 12* base timing, Maxed out pump, and it takes about 4min of wide open throttle to hit 1200*, welded wastegate custom downpipe, ported compressor, i seem to run 12psi all the time then 15psi when its warmish..

Ideas? Oh there is a a/c condenser, ps cooler, and intercooler infront of the radiator.


This is the only pic i have showing the front. You think i need to cut the holes in the bumper for more cooling?


This is the radiator in it. Its got like 10k on it.
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #2
guess i cant edit..

By warm i mean, cruising 190 and pulling a hill or driving hard high rpm for a bit 210-220. Doesnt get much hotter than that. I can watch the gauge move up and down while driving when its warm. I wonder if its a bad thermostat again
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #4
It never used to do this though. Ive owned this engine for 6 years
 

·
Super Moderator
Joined
·
4,247 Posts
Are you using a Ford or IH thermostat? You *should be* ;)

Are you *sure* the gauge is reading correctly? There is a voltage regulator and printed circuit panel on the back of the cluster that are prone to corrosion that can cause gauges to read in error, or even not at all.
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #6
Its a international thermostat from when i worked there.. Its a autometer a-pilar gauge. The stock gauge goes from "N" on normal to "L" when hot.
 

·
TDG MAFIA
Joined
·
730 Posts
Never go by the stock gauge. They dont show an accurate temperature/pressure reading at anything.

Test your thermostat to make sure it opens at the temp it should be. Maybe your radiator is starting to plug up.
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #8
I HAVE A A-PILLAR AUTOMETER GAUGE...

If im going to go though the trouble of pulling the thermostat out then im going to change it. Its not that old, and neither is the radiator. The coolant is new and clean.

 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #10
190-200 towing wide open.

The other day i was on the fwy and with th a/c on not towing it was just staying at 220 and kept wanting to go higher. The fan was on and the weird part was that I could watch the gauge go up and down.
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #11
ok so i noticed that if i hold it over 2500 for a bit the fan wont turn on and it starts to overheat. I thought fan clutches were supposed to turn off at 2500 but i dont think i have enough flow through the radiator when the fan isnt on
 

·
Senior Member
Joined
·
101 Posts
I think the holes in the bumper would help out, when ordering a grill guard they ask with or without turbo vents. the gassers didn't have them only the diesels did, I'm a firm believer of if it came that way there was probably a reason for it. :shrugs
 

·
Senior Member
Joined
·
455 Posts
my truck runs just under 210 unloaded at 65 on the highway. thats with out the fan even on the truck and the water pump leaking. i will occasionally see it go down a bit
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #14
Im thinking my oil cooler might be getting plugged
 

·
Senior Member
Joined
·
455 Posts
its a good possibility. i had my truck running for 3 hours last night on with the high idle solenoid hot wired trying to jump a buddies 6.0 after head gasket job, and it didnt go much past 210 still without the fan and withe the bad water pump. oil temp was around 180 or so
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #16
It never gets hot when im wheeling or idling just on long pulls. Im going to put a oil temp gauge on it and see whats going on.
 

·
Member
Joined
·
1,060 Posts
before cutting up your bumper i would remove the bumper and see if the extra flow helps... good luck on your hunt.
 

·
Senior Member
Joined
·
455 Posts
what are your egts runnin?
 

·
Senior Member
Joined
·
567 Posts
Discussion Starter #19
I cannot get it over 1250 wot. And that's after a few min.
 
1 - 19 of 19 Posts
Top