The Diesel Garage banner

1 - 10 of 10 Posts

·
Junior Member
Joined
·
54 Posts
Discussion Starter #1
Hey guys I have been MIA awhile on the sight so need to catch up on whats new in the truck world but in the meantime maybe you guys can help me out.

I have had my Spartan tuner for about 10K miles now at least and I LOVE it!
I run the 275 tune from day 1 and have had no issues w/ the truck till this week....Last week the Check Engine light came on, got the tuner to read the code and it wouldnt read the code for some reason but it let me clear it and it hasnt come back yet since....However, 2 days after I pulled out in traffic and mashed the gas, took off like a jet and about 60mph it just fell on its face and felt like I hit a wall...Fuel Cutoff is my guess, then it would accelerate slowly but if I tried to give it moderate or more gas it would start bucking like crazy till I let off the gas...Did this the whole way home...I turned the truck off, started again 20 mins later and the truck ran perfect even beating on it...Been fine until today same thing...Pulled out in traffic, mashed the gas and the fuel cutoff about 60 or so...Then truck would buck if I gave it to much gas....I pulled over, turned truck off and back on right away and it ran beautiful the rest of the way home....Any ideas??? Thing its something in the Spartan Programming? SOmething with the truck itself? Any ideas would be great :)
 

·
Registered
Joined
·
639 Posts
Its gonna be a P0088 code...high rail pressure...some trucks are seeing it under load as the outside temps are getting higher.
 

·
Junior Member
Joined
·
54 Posts
Discussion Starter #3
Hmmm...It has been hot as hell in South Florida also...Any ideas for a fix or something I have to deal with?
 

·
Registered
Joined
·
639 Posts
Hmmm...It has been hot as hell in South Florida also...Any ideas for a fix or something I have to deal with?
I think they are working on it..not sure, I thought I read that it had something to do with the calibration of specific trucks.
 

·
cool as december
Joined
·
1,032 Posts
I think there was a thread on the org and matt had said to e-mail [email protected] diesel tech and tell them you are throwing the code, include the vin, strategy, and serial numbers for the ecm and tcm.
 

·
Registered
Joined
·
146 Posts
Hey guys I have been MIA awhile on the sight so need to catch up on whats new in the truck world but in the meantime maybe you guys can help me out.

I have had my Spartan tuner for about 10K miles now at least and I LOVE it!
I run the 275 tune from day 1 and have had no issues w/ the truck till this week....Last week the Check Engine light came on, got the tuner to read the code and it wouldnt read the code for some reason but it let me clear it and it hasnt come back yet since....However, 2 days after I pulled out in traffic and mashed the gas, took off like a jet and about 60mph it just fell on its face and felt like I hit a wall...Fuel Cutoff is my guess, then it would accelerate slowly but if I tried to give it moderate or more gas it would start bucking like crazy till I let off the gas...Did this the whole way home...I turned the truck off, started again 20 mins later and the truck ran perfect even beating on it...Been fine until today same thing...Pulled out in traffic, mashed the gas and the fuel cutoff about 60 or so...Then truck would buck if I gave it to much gas....I pulled over, turned truck off and back on right away and it ran beautiful the rest of the way home....Any ideas??? Thing its something in the Spartan Programming? SOmething with the truck itself? Any ideas would be great :)
We would need the code to help diagnose what is happening with your truck. Are you checking both the generic and the Ford specific codes?
 

·
Junior Member
Joined
·
54 Posts
Discussion Starter #7
Hey Nutty....The DD wouldnt read the code it through for some reason...Tried 5 times and kept giving me some sort of error reading message but it did let me clear it when I chose that feature....Hant come back yet since I cleared it but the truck has acted like I stated....Pahrump I think was assuming based on how the truck is acting that it was that code he mentioned....Sound correct to you on what truck is doing or do you have another idea?
Thanks
 

·
Senior Member
Joined
·
2,183 Posts
if its not reading the codes you may need to update the DD. but we'll wait for mick's expertise on that
 

·
cool as december
Joined
·
1,032 Posts
Yeah sounds to me like its needing an update or maybe the Ford specific didnt get loaded right...
 

·
Registered
Joined
·
11 Posts
My truck did the same thing the other day. During the time the truck was acting up, the trans was shifting funny to. I reloaded the tune and it still did it. Let it set for a couple hours and drove it to town and everything was fine. It never threw a code. The temperature was in the mid 90's.
 
1 - 10 of 10 Posts
Top