The Diesel Garage banner

1 - 4 of 4 Posts

·
Member
Joined
·
139 Posts
Discussion Starter #1
Last week it was cold (-35 C) and I recieved a warning chime and statement on my display that said "Service Advance Trac". When stoped and driving the symbol on the display would show the wheels were spinning but obviously wern't.

Has anyone had experience with this?

2011 SD CC 4x4 XLT with 66,000 km's is all.

Thanks.
 

·
Member
Joined
·
139 Posts
Discussion Starter #2
As a secondary question, does anyone know if you can permanently disable or shut off the traction control module? This feature is a joke and has put me in the ditch 4 times due to the way it works.

I know how to drive in adverse weather and road conditions, especially in 4 wheel drive and this thing just takes away the power and slows everything up so it just goes straight into the ditch.

I freakin hate this feature.
 

·
Junior Member
Joined
·
10 Posts
DITTO on a way to permanently disable this "feature". Even if you turn it off with will automatically reactivate at speeds over 35mph.

 

·
Member
Joined
·
139 Posts
Discussion Starter #4
Last week it was cold (-35 C) and I recieved a warning chime and statement on my display that said "Service Advance Trac". When stoped and driving the symbol on the display would show the wheels were spinning but obviously wern't.

Has anyone had experience with this?

2011 SD CC 4x4 XLT with 66,000 km's is all.

Thanks.
Had to have a sensor replaced ($75.00 + $120 diagnostic cost + $75 installation) for $270 + taxes, and not on warranty. Affects ABS but still wouldn't warranty it.
 
1 - 4 of 4 Posts
Top