The Diesel Garage banner

1 - 4 of 4 Posts

·
Junior Member
Joined
·
13 Posts
Discussion Starter #1
OK guys i have a problem i just bought a SCT SF3 tuner i plug it in to the OBDII port and the tuner starts up i press program vehicle turn key on turn key off as it tells me to do comes up 6.0l diesel i press that it says begin programing i press that it says turn key on i do thats when my problem starts the message center im my trucks says TBC FAULT and nothing happens the tuner says uploading ECU please wait. i let it sit for 1/2 hour and nothing tuner still says uploading ECU please wait.I called SCT and they said its a communication problem on my end.PLEASE HELP!!

2006 F250 6.0L
 

·
Senior Member
Joined
·
3,051 Posts
Check your fuses for the lighter or aux power outlet, one of them also powers up the obd2 port that the tuner is plugged into. I had issues with my new sf3 several times while trying to load tunes, it made my truck not run and lost the stock file. Had to send my tuner in to sct for warranty repair. Got it back awhile ago but have not used it yet, gun shy for now. The supposedly stock file that sct got my truck running again with, which has pilot injection activated as it did back in 03', runs and shifts good for all around performance and towing, so I've left it alone for now. Sct replaced the bootloader in my device, said it was faulty. The sct tech support was very helpful with me, I would think they could resolve your issue. You may end up having to send it in like I did. Harry
 

·
Senior Member
Joined
·
3,051 Posts
I just read your other thread, so I guess you got your tuner to load now. I guess you can disregard my above post. Harry
 

·
Junior Member
Joined
·
13 Posts
Discussion Starter #4
Hey thanks for the help i dont know what i did but got it to load and now it works every time.I unplugged the computer and blew out the connection and took every fuse out and put back together works fine.I dont know what was up?
 
1 - 4 of 4 Posts
Top